Skocz do zawartości

baltazar_gabka

Użytkownicy
  • Zawartość

    71
  • Rejestracja

  • Ostatnio

Reputacja

0 Normalna

1 obserwujący

O baltazar_gabka

  • Ranga
    Często na forum

Metody kontaktu

  • Strona WWW
    http://www.forumgokarty.ovh/
  • ICQ
    690950086

Informacje profilowe

  • Płeć
    Mężczyzna
  • Skąd
    wlkp
  1. Witam. Próbuję skonfigurować nginx i uwsgi według tego opisu: https://uwsgi-docs.readthedocs.io/en/latest/tutorials/Django_and_nginx.html Niestety mam problem z poprawnym ustawieniem socketów. Po stronie nginx mam taki wpis: upstream django { server unix:////home/pawel/www/uwsgi-tutorial/mysite/mysite.socket; } po stronie uwsgi mam coś takiego: [uwsgi] chdir = /home/pawel/www/uwsgi-tutorial/mysite module = mysite.wsgi home = /home/pawel/www/uwsgi-tutorial master = true processes = 10 socket = mysite.socket vacumm = true po uruchomieniu uwsgi mam błąd wynikający z braku dostępu do socketu. po dodaniu poniższej linijki do pliku konfiguracyjnego uwsgi: --chmod-socket=666 wszystko działa prawidłowo. srw-rw-rw- 1 pawel pawel 0 kwi 3 16:47 mysite.socket root 249 0.0 0.3 91852 1720 ? Ss 16:25 0:00 nginx: master process /usr/sbin/nginx -g daemon on; master_process on; www-data 252 0.0 0.4 91852 2372 ? S 16:25 0:00 nginx: worker process www-data 253 0.0 0.4 91852 2372 ? S 16:25 0:00 nginx: worker process www-data 254 0.0 0.5 91852 2804 ? S 16:25 0:00 nginx: worker process www-data 255 0.0 0.4 91852 2352 ? S 16:25 0:00 nginx: worker process Będę wdzięczny za wskazówki od bardziej zaawansowanych użytkowników.
  2. nginx + fcgiwrap - bład 403 Forbidden

    W pliku /etc/nginx/fcgiwrap.conf dodałem: fastcgi_pass unix:/var/run/fcgiwrap.socket; W nginx dodałem także wpis: fastcgi_pass unix:/var/run/fcgiwrap.socket; W logach nginx nie ma żadnych błędów. W przeglądarce wyświetla się tylko napis: 403 Forbidden Z tego co widzę to fcgiwrap jest uruchomiony z użytkownika www-data. Chociaż gdzie jest to ustawione to nie wiem. ps aux | grep fcgiwrap www-data 5589 0.0 0.0 26320 928 ? Ss 12:02 0:00 /usr/sbin/fcgiwrap EDIT: Zmieniłem prawa do pliku index.cgi na 755 i teraz poszło.
  3. nginx + fcgiwrap - bład 403 Forbidden

    ls -la /var/run/ | grep fcgi srw-rw-rw- 1 root root 0 gru 8 23:45 fcgiwrap.socket Sa prawa rw. Czy po stronie nginx i configa fcgiwrap muszą być te same sockety ?
  4. nginx + fcgiwrap - bład 403 Forbidden

    Zmieniłem index.pl na index.cgi i teraz mam taki błąd: 2016/12/09 22:05:19 [crit] 5208#0: *1 connect() to unix:/run/fcgiwrap.sock failed (2: No such file or directory) while connecting to upstream, client: 88.151.138.228, server: domena.pl, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/run/fcgiwrap.sock:", host: "domena.pl" 2016/12/09 22:05:19 [crit] 5208#0: *1 connect() to unix:/run/fcgiwrap.sock failed (2: No such file or directory) while connecting to upstream, client: 88.151.138.228, server: domena.pl, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/run/fcgiwrap.sock:", host: "domena.pl" ls -la /run | grep fcgi srw-rw-rw- 1 root root 0 gru 8 23:45 fcgiwrap.socket
  5. Witam. Próbuję uruchmić skrypt CGI na swoim serwerze. Mam postawiony nginx + fcgiwrap. Fcigwrap instalowałem zgodnie z ta instrukcją: https://www.nginx.com/resources/wiki/start/topics/examples/fcgiwrap/ aptitude install fcgiwrap cp /usr/share/doc/fcgiwrap/examples/nginx.conf /etc/nginx/fcgiwrap.conf mkdir /var/www/cgitest touch /var/www/cgitest/index.cgi vim /var/www/cgitest/index.cgi ls -la /var/www drwxr-xr-x 4 root root 4096 gru 9 21:29 . drwxr-xr-x 13 root root 4096 gru 8 20:12 .. drwxr-xr-x 2 root root 4096 gru 9 21:30 cgitest W nginx mam coś takiego: server { listen 80; server_name domena.pl; root /var/www/cgitest; include /etc/nginx/fcgiwrap.conf; location / { index index.html index.htm index.pl; } location ~ \.pl|cgi$ { try_files $uri =404; gzip off; fastcgi_pass unix:/run/fcgiwrap.sock; fastcgi_index index.cgi; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; } } Po restarcie serwera w logach są takie wpisy: 016/12/09 21:33:06 [error] 5160#0: *1 directory index of "/var/www/cgitest/" is forbidden, client: 88.151.138.228, server: domena.pl, request: "GET / HTTP/1.1", host: "domena.pl" Plik fcgiwrap.conf wygląda następująco: location /cgi-bin/ { gzip off; root /usr/lib; fastcgi_pass unix:/var/run/fcgiwrap.socket; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME /usr/lib$fastcgi_script_name; } Katalogu /usr/lib/cgi-bin nie ma na mojej maszynie. Czy tak powinien wyglądać ten plik? Z czego może wynikać błąd 403?
  6. Problem z dodaniem reguły do iptables

    Poniższe polecenie nie powoduje błędu: iptables -A INPUT -p tcp --dport 5022 -j ACCEPT /tmp# iptables -L Chain INPUT (policy ACCEPT) target prot opt source destination ACCEPT tcp -- anywhere anywhere tcp dpt:ssh ACCEPT tcp -- anywhere anywhere tcp dpt:5022 Chain FORWARD (policy ACCEPT) target prot opt source destination Chain OUTPUT (policy ACCEPT) target prot opt source destination Natomiast jak dodaje opcję "-m state --state NEW" to już nie przechodzi.
  7. Problem z dodaniem reguły do iptables

    Mam. iptables -L Chain INPUT (policy ACCEPT) target prot opt source destination Chain FORWARD (policy ACCEPT) target prot opt source destination Chain OUTPUT (policy ACCEPT) target prot opt source destination Mam jeszcze taki błąd: modprobe ip_tables modprobe: FATAL: Module ip_tables not found. uname -r 2.6.32-042stab108.3
  8. Witam. Próbuje na VPS dodać taką regułę: iptables -A INPUT -p tcp -m state --state NEW --dport 5022 -j ACCEPT w wyniku otrzymuję: iptables: No chain/target/match by that name. Jeśli chodzi o iptables to jestem zielony. Będę wdzięczny za jakąś wskazówkę.
  9. Witam. Od jakiegoś czasu mam problem z moim VPS. Podczas próby aktualizacji systemu mam taki komunikat: aptitude update FATAL -> Failed to fork. Wygląda jakby było mało pamięci RAM ale polecenie free pokazuje jeszcze ponad 1.9GB wolnego. free -m -t total used free shared buffers cached Mem: 2048 145 1902 0 0 82 -/+ buffers/cache: 63 1984 Swap: 0 0 0 Total: 2048 145 1902 Co ciekawe jak wyłączę MySQL to tego problemu nie ma. Wyniki z ulimit: core file size (blocks, -c) 0 data seg size (kbytes, -d) unlimited scheduling priority (-e) 0 file size (blocks, -f) unlimited pending signals (-i) 255478 max locked memory (kbytes, -l) 64 max memory size (kbytes, -m) unlimited open files (-n) 1024 pipe size (512 bytes, -p) 8 POSIX message queues (bytes, -q) 819200 real-time priority (-r) 0 stack size (kbytes, -s) 10240 cpu time (seconds, -t) unlimited max user processes (-u) 255478 virtual memory (kbytes, -v) unlimited file locks (-x) unlimited Ma ktoś jakieś pomysły w czym może być problem ?
  10. Problem z spf na hotmail

    Spf mam już od dawna skonfigurowane. Dzisiaj dodąłem jeszcze dkim. Zobacze jutro może przejdzie. Podobno dwa razy dziennie jest aktualizacja.
  11. Problem z spf na hotmail

    Czytałem tą stronę. Nawet wysyłałem maila. Dostałem zwrotkę od nich: Diagnostic-Code: smtp;550 5.1.1 RESOLVER.ADR.RecipNotFound; not found
  12. Problem z spf na hotmail

    Witam.Mam problem z wysyłaniem poczty do hotmail.Gdy wysyłam maila na skrzynkę hotmail - maile nie dochodzą.Po dodanu adresu email do adresów - maile zaczynają dochodzić.W nagłówku mam taki coś: Authentication-Results: hotmail.com; spf=temperror (sender IP is 91.234.146.70) smtp.mailfrom=pawel@example.net; dkim=pass Co ciekawe spf na gmail i o2 wyglada tak: Received-SPF: pass (mx13.o2.pl: domain of pawel@example.net Miał ktoś podobny problem?
  13. Konfiguracja rekordu MX dla wielu domen

    @spindritf, dzieki za pomoc
  14. Witam. Jak powinny być skonfigurowane rekordy MX dla wielu domen. Powiedzmy, że dla głównej domeny mam taki wpis: mail IN A XX.YY.ZZ.QQ ;; aliases www IN CNAME @ ;; mail @ IN MX 10 mail.domena.pl. @ IN TXT "v=spf1 a ip4:XX.YY.ZZ.QQ -all" @ IN SPF "v=spf1 a ip4:XX.YY.ZZ.QQ -all" Powiedzmy, że mam nastepną domenę: domena2.pl Jak powinna w tym przypadku powinny wygladać wpisy MX dla tej domeny? Wpisy powinny być identyczne?? ;; mail @ IN MX 10 mail.domena.pl. @ IN TXT "v=spf1 a ip4:XX.YY.ZZ.QQ -all" @ IN SPF "v=spf1 a ip4:XX.YY.ZZ.QQ -all" Nie mogę znaleźć nic na ten temat. Będę wdzieczny za pomoc.
  15. Maile z mojego serwera pocztowego trafiają do spamu

    Trochę pzmieniałem w konfiguracji. Zmieniłem RevDNS: nslookup 91.234.146.70 Server: 8.8.8.8 Address: 8.8.8.8#53 Non-authoritative answer: 70.146.234.91.in-addr.arpa name = server.pagu.waw.pl. Obecnie DNS wyglada następująco: @ IN MX 10 mail.pagu.waw.pl. @ IN TXT "v=spf1 a mx ptr mx:mail.pagu.waw.pl ip4:91.234.146.70/32 -all" PS. Nie wiem czy tutaj może być mail.pagu.waw.pl czy musi być server.pagu.waw.pl. Jeśli ktoś wie to proszę o odpowiedź. Źródło maila z gmail: Delivered-To: XXX@gmail.com Received: by 10.58.237.161 with SMTP id vd1csp243148vec; Wed, 28 May 2014 08:57:39 -0700 (PDT) X-Received: by 10.180.12.135 with SMTP id y7mr1948538wib.39.1401292658484; Wed, 28 May 2014 08:57:38 -0700 (PDT) Return-Path: <kontakt@pagu.waw.pl> Received: from server.pagu.waw.pl ([91.234.146.70]) by mx.google.com with ESMTP id g5si14605165wiy.35.2014.05.28.08.57.32 for <XXX@gmail.com>; Wed, 28 May 2014 08:57:32 -0700 (PDT) Received-SPF: pass (google.com: domain of kontakt@pagu.waw.pl designates 91.234.146.70 as permitted sender) client-ip=91.234.146.70; Authentication-Results: mx.google.com; spf=pass (google.com: domain of kontakt@pagu.waw.pl designates 91.234.146.70 as permitted sender) smtp.mail=kontakt@pagu.waw.pl Received: by server.pagu.waw.pl (Postfix, from userid 1000) id 8032653C8753; Wed, 28 May 2014 19:57:27 +0400 (MSK) To: XXX@gmail.com Subject: Temat wiadomosci X-PHP-Originating-Script: 1000:rcube.php MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII; format=flowed Content-Transfer-Encoding: 7bit Date: Wed, 28 May 2014 17:57:27 +0200 From: Darmowy Katalog <kontakt@pagu.waw.pl> Message-ID: <d960f59d688e094215c052ca3689a9af@pagu.waw.pl> X-Sender: kontakt@pagu.waw.pl User-Agent: Roundcube Webmail/1.0.1 Zródło maila z outlook.com x-store-info:4r51+eLowCe79NzwdU2kRyU+pBy2R9QCF+Io0PkgWkLZQMJNkFxR9QtkZwsPr2mH7YNdBaYXzfRwUGP0/GDFP0wghgu4VQdVVsp6nJa5hvn+zFQNbpTqGpDLoFmnqCO1kRPXS08eJuM= Authentication-Results: hotmail.com; spf=temperror (sender IP is 91.234.146.70) smtp.mailfrom=kontakt@pagu.waw.pl; dkim=none header.d=pagu.waw.pl; x-hmca=none header.id=kontakt@pagu.waw.pl X-SID-PRA: kontakt@pagu.waw.pl X-AUTH-Result: NONE X-SID-Result: NONE X-Message-Status: n:n X-Message-Delivery: Vj0xLjE7dXM9MDtsPTA7YT0wO0Q9MjtHRD0yO1NDTD02 X-Message-Info: 11chDOWqoTnep3H0pMNlwOpOUTYpHoaN5qiAp7S5Ay2YKpG/rQJqqXySF38c0odW94yamMFlZ+l6F0jRzaooAYz00yWNae/8n6EH1RBK0ddvBK2Jh288IFiOq23PdojVydszYqEBN40cxDkCtDu/jZ0Blo4rWK8nmUytTg64RdJms2rQegphwcfaB6YCKuZveu/S592vFeMW7HMLxPh0mu9vEwj9A1BI Received: from server.pagu.waw.pl ([91.234.146.70]) by BAY0-MC6-F7.Bay0.hotmail.com with Microsoft SMTPSVC(6.0.3790.4900); Wed, 28 May 2014 09:06:49 -0700 Received: by server.pagu.waw.pl (Postfix, from userid 1000) id DF89F53C8753; Wed, 28 May 2014 20:06:48 +0400 (MSK) To: XXX@outlook.com Subject: Temat Wiadomosci X-PHP-Originating-Script: 1000:rcube.php MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII; format=flowed Content-Transfer-Encoding: 7bit Date: Wed, 28 May 2014 18:06:48 +0200 From: Darmowy Katalog <kontakt@pagu.waw.pl> Message-ID: <ac153ee5dd9213338c3c8f8b416a7ded@pagu.waw.pl> X-Sender: kontakt@pagu.waw.pl User-Agent: Roundcube Webmail/1.0.1 Return-Path: kontakt@pagu.waw.pl X-OriginalArrivalTime: 28 May 2014 16:06:50.0093 (UTC) FILETIME=[D561B9D0:01CF7A8E] Niestety maile nadal trafiają do spamu.
×