Skocz do zawartości


 

Zdjęcie

VestaCP - nie działa poczta przychodząca.

VestaCP - nie działa poczta przychodząca.

  • Proszę się zalogować aby odpowiedzieć
12 odpowiedzi na ten temat

VestaCP - nie działa poczta przychodząca.

#1 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 14 lipiec 2017 - 11:46

Witajcie.

 

Zainstalowałem pakiet do zarządzania serwerem VestaCP na Ubuntu Server 16.04 .

Strona www działa. FTP działa. Z pocztą są problemy.

Poczta wychodząca przez webmail działa - wychodzi i jest doręczona.

Poczta przychodząca niestety nie działa. Poczta nie dochodzi.

 

Co muszę sprawdzić??

 

Podpowiedzcie proszę.


Edytowany przez kpietrek, 14 lipiec 2017 - 12:00.

  • 0

#2 strefapc

strefapc

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 608 postów
  • Skąd:Białystok
  • Firma:PHU StrefaPC
  • Imię:Piotr
  • Nazwisko:Wyszyński

Napisany 14 lipiec 2017 - 13:07

Rekordy MX masz dobrze skonfigurowane?


  • 0

#3 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 14 lipiec 2017 - 13:24

Taki mam wpis:


@    MX    10    mail.testujemy.glogow.pl.

Tylko zastanawia mnie taki wpis i nie mogę go zmienić:


@    NS    ns2.localhost.ltd.
@    NS    ns1.localhost.ltd.


Edytowany przez kpietrek, 14 lipiec 2017 - 13:26.

  • 0

#4 webh

webh

    Stały użytkownik

  • Firma Bronze
  • PipPipPipPipPip
  • 103 postów
  • Firma:Ultimahost.pl Szeliga sp.j.

Napisany 14 lipiec 2017 - 14:46

W tej chwili ani domena

testujemy.glogow.pl

ani

mail.testujemy.glogow.pl

nie daje żadnych rezultatów przy próbie odszukania adresu IP. Przynajmniej w drugim przypadku jest to podstawowa przyczyna.

Wygląda to na jakiś problem z DNSem. Czy dodałeś w panelu strefę DNS dla tej domeny?  Może tu jest problem?

 


Edytowany przez webh, 14 lipiec 2017 - 14:47.

  • 0

#5 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 14 lipiec 2017 - 14:57

Jak nie ma poprawnych DNSów to nie będzie działać - https://intodns.com/...ujemy.glogow.pl


  • 0

#6 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 14 lipiec 2017 - 15:11

Kurcze więc gdzie jest błąd?? Uczę się tego i nie bardzo wiem już gdzie tego szukać. Pomóżcie proszę.

W DNS mam tak:

 

Załączony plik  dns1.jpg   50,09K   5 pobrań Załączony plik  dns2.jpg   32,46K   5 pobrań Załączony plik  dns3.jpg   35,74K   5 pobrań

 


Edytowany przez kpietrek, 14 lipiec 2017 - 15:34.

  • 0

#7 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 14 lipiec 2017 - 15:12

Brakuje ci rekordów A z ns1 / ns2 i poprawić rekordy NS musisz na prawidłowe zamiasdt localhost.ltd.


  • 0

#8 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 14 lipiec 2017 - 15:35

Teraz już jest lepiej.

Wróciłem do pierwotnego ustawienia Bind w /etc/bind

Po instalacji VestaCP dopisało mi strefę do /etc/bind/named.conf i wyglądało tak:

// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";

zone "testujemy.glogow.pl" {type master; file "/home/admin/conf/dns/testujemy.glogow.pl.db";};

Ale to nie chciało działać. Raport też już jest lepszy ale dalej coś nie działa jeszcze jak należy.

A po wysłaniu teraz maila dostaję odpowiedź (wcześniej jej było brak) :

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

pietrek@testujemy.glogow.pl
all relevant MX records point to non-existent hosts

Jak już wcześniej pisałem nie wiem czemu nie mogłem zmienić tych ustawień NS.

Przy próbie zmiany mam komunikat:

Error: IN A ns2.testujemy.glogow.pl does not exist

Usunąłem tę strefę i dodałem ponownie. Teraz już NS się zmieniły na prawidłowe. Dopisało mi linijki do dwóch domen bo założyłem i drugą. Ale raport nadal mi pokazuje błędy wg. tego wpisu named.conf :

// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the 
// structure of BIND configuration files in Debian, *BEFORE* you customize 
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
zone "testujemy1.glogow.pl" {type master; file "/home/admin/conf/dns/testujemy1.glogow.pl.db";};
zone "testujemy.glogow.pl" {type master; file "/home/admin/conf/dns/testujemy.glogow.pl.db";};


Edytowany przez kpietrek, 14 lipiec 2017 - 16:16.

  • 0

#9 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 14 lipiec 2017 - 18:35

Ktoś chętny spojrzeć na moją konfigurację udostępnię dane do logowania.


  • 0

#10 webh

webh

    Stały użytkownik

  • Firma Bronze
  • PipPipPipPipPip
  • 103 postów
  • Firma:Ultimahost.pl Szeliga sp.j.

Napisany 14 lipiec 2017 - 19:19

Ktoś chętny spojrzeć na moją konfigurację udostępnię dane do logowania.

 

Podeślij, zerkniemy :)


  • 0

#11 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 15 lipiec 2017 - 07:30

A więc tak. DNS już raczej działają. Natomiast po wysłaniu poczty na domenę która jest skonfigurowana w VESTACP dostaję odpowiedź:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  pietrek@testujemy.glogow.pl
      all relevant MX records point to non-existent hosts

  • 0

#12 TaniDedyk.pl

TaniDedyk.pl

    Nowy użytkownik

  • Firma Bronze
  • 21 postów
  • Firma:Marek.pro Marek Drzewiecki

Napisany 15 lipiec 2017 - 08:36

Dodaj na końcu rekordu kropkę, bo źle "widać" MX-a:

10   mail.testujemy.glogow.pl.testujemy.glogow.pl   ['']   [TTL=25900]


  • 0

#13 kpietrek

kpietrek

    Nowy użytkownik

  • Użytkownicy
  • 10 postów

Napisany 15 lipiec 2017 - 08:59

Dodaj na końcu rekordu kropkę, bo źle "widać" MX-a:

10   mail.testujemy.glogow.pl.testujemy.glogow.pl   ['']   [TTL=25900]

 

Na koniec którego rekordu, bo na MX mam kropkę:


ns2        A        89.72.202.64
ns1        A        89.72.202.64
_dmarc    TXT       "v=DMARC1; p=none"
@         TXT       "v=spf1 a mx ip4:89.72.202.64 ?all"
@         MX   10   mail.testujemy.glogow.pl.
ftp        A        89.72.202.64
pop        A        89.72.202.64
www        A        89.72.202.64
mail       A        89.72.202.64
@          A        89.72.202.64
@         NS        ns2.testujemy.glogow.pl.
@         NS        ns1.testujemy.glogow.pl.


Edytowany przez kpietrek, 15 lipiec 2017 - 09:03.

  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników