Skocz do zawartości


 

Zdjęcie

MySQL - zjada dużo ramu

MySQL - zjada dużo ramu

  • Proszę się zalogować aby odpowiedzieć
3 odpowiedzi na ten temat

MySQL - zjada dużo ramu

#1 murgal

murgal

    Stały użytkownik

  • WHT Pro
  • PipPipPipPipPip
  • 330 postów

Napisany 09 grudzień 2015 - 15:00

Cześc

 

Mam małą bazę MySQL, serwer dell w którym jest 8 gb ram i aktualnie korzystam już ze swapa... Mógłby ktoś zerknąć jak troszkę odciążyć ram?

 

 

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html
# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port  = 3306
socket  = /var/run/mysqld/mysqld.sock
# Here is entries for some specific programs
# The following values assume you have at least 32M ram
# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket  = /var/run/mysqld/mysqld.sock
nice  = 0
[mysqld]
#
# * Basic Settings
#
user  = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket  = /var/run/mysqld/mysqld.sock
port  = 3306
basedir  = /usr
datadir  = /var/lib/mysql
tmpdir  = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address  = 127.0.0.1
#
# * Fine Tuning
#
key_buffer  = 16M
key_buffer_size         = 32MB

#slow query
slow_query_log = ON
long_query_time = 0.5
slow_query_log_file = "/var/log/mysql/slowq.log"

table_open_cache        = 1200
max_allowed_packet = 16M
thread_stack  = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit = 16M
query_cache_size        = 128M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error log - should be very few entries.
#
log_error = /var/log/mysql/error.log
#
# Here you can see queries with especially long duration
#slow_query_log_file = /var/log/mysql/mysql-slow.log
#slow_query_log      = 1
#long_query_time = 2
#log_queries_not_using_indexes
join_buffer_size        = 512K
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id  = 1
#log_bin   = /var/log/mysql/mysql-bin.log
expire_logs_days = 10
max_binlog_size         = 100M
#binlog_do_db  = include_database_name
#binlog_ignore_db = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem
[mysqldump]
quick
quote-names
max_allowed_packet = 16M
[mysql]
#no-auto-rehash # faster start of mysql but no tab completition
[isamchk]
key_buffer  = 32M
#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/

  • 0

#2 SiXwishlist

SiXwishlist

    Freedom Forever

  • Firma Bronze
  • PipPipPipPipPipPipPipPip
  • 2366 postów
  • Skąd:Great Britain
  • Firma:SiXwishlist

Napisany 09 grudzień 2015 - 15:07

Zainteresuj sie tym: http://mysqltuner.com/ Jak bys potrzebował przeliczyć to tym: http://www.mysqlcalculator.com/ A jak byś chciał zlecić coś to adres email w profilu ;)


  • 0

#3 gutek

gutek

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 209 postów
  • Skąd:Wrocław

Napisany 09 grudzień 2015 - 15:18

Z tego pliku nie wiele wynika a raczej wg mnie nie ma ustawień pozwalających na duże wykorzystanie RAMu. Jakie masz tabele w bazach bo nie masz wogóle konfiguracji innodb, być może ono się rozpędza..


  • 0

#4 Misiek08

Misiek08

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1157 postów

Napisany 11 grudzień 2015 - 03:01

http://mysqltuner.pl


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników