Skocz do zawartości
Zaloguj się, aby obserwować  
'z czym do ludzi'

Serwer SAMP, błąd podczas startu

Polecane posty

Jak w tytule wątku.

 

> root@saint-rp:~# tar -zxf samp03esvr_R2.tar.gz
> root@saint-rp:~# cd samp03
> root@saint-rp:~/samp03# nano server.cfg
> root@saint-rp:~/samp03# cd /home/samp/samp03/
> -bash: cd: /home/samp/samp03/: No such file or directory
> root@saint-rp:~/samp03# screen ./samp03svr
> [screen is terminating]
> root@saint-rp:~/samp03# ls
> LICENSE  announce	   gamemodes  npcmodes  samp03svr    server.cfg
> README   filterscripts  include    samp-npc  scriptfiles
> root@saint-rp:~/samp03# screen ./samp03svr
> [screen is terminating]
> root@saint-rp:~/samp03# cd /root/samp03/
> root@saint-rp:~/samp03# screen ./samp03svr
> [screen is terminating]
> root@saint-rp:~/samp03#
>

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Gdzie tu masz błąd ?

 

Poza tym powodzenia w stawianiu aplikacji na root ;)

Edytowano przez xorg (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Może najpierw odpal serwer bez screena i zobacz jaki jest efekt a dopiero potem użyj screena.

 

Ale najpierw opanuj wiedzę do jak działa screen i do czego służy oraz podstawy linuxa.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A jak odpalić serwera bez screena? Pliki serwera znajdują się w root/samp03. Więc wchodzę "cd /root/samp03/" i

 

Edit:

gdy próbuje odpalić, piszę

 

Cannot exec './samp03svr': No such file or directory

 

Edytowano przez 'z czym do ludzi' (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A rozumiesz co tam Ci napisało "No such file or directory" ?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Nie ma takiego pliku, ale tak na prawdę znajduje się on w root/samp03 więc o co chodzi? O_o

 

Edit: Nadawałem chmod dla samp03svr i zainstalowałem ponownie screena, lecz nadal to samo.

Edytowano przez 'z czym do ludzi' (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
root@saint-rp:~# cd /root/samp03/
root@saint-rp:~/samp03# chmod +x samp03svr
root@saint-rp:~/samp03# ./samp03svr
-bash: ./samp03svr: No such file or directory
root@saint-rp:~/samp03#

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witam,

 

1. daj wynik z

head samp03svr

 

2. Nie masz przypadkiem systemu 64bitowego, a plików pod 32bitowy? albo w drugą stronę?

 

Pozdrawiam

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Serwer SA-MP pobierałem stąd http://files.sa-mp.c...3esvr_R2.tar.gz a system VPSa to debian-6.0-x86_64.

 

apt-get install ia32-libs i uruchom serwer.

 

@up, plik jest skoro head zadziałał :)

Edytowano przez www.gamebit.pl (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Działa. Ale po wyłączeniu PUTTY, serwer wyłącza się.

 

PS. Nie mogę dać reputacji gdyż nie mam wystarczającej ilości postów ;/

 

Edit: Wystarczyło screen ./samp03svr i wszystko poprawnie, śmiga.

Edytowano przez 'z czym do ludzi' (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Do tego służy screen żeby zostawić go w tle.

 

np. uruchamiasz screen potem samp potem robisz ctrl+a+d lub wpisujesz screen -d i wylogowujesz się z putty.

Przy kolejnym logowaniu robisz screen -r i przywraca Ci sesję.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się

Zaloguj się, aby obserwować  

×