Skocz do zawartości
Wonszur

MySQL na hosting mintshost.pl

Polecane posty

Cześć wszystkim,

 

dzisiaj próbowałem zainstalować sobie z Ciekawości Xibo Open Source Digital Signage CMS na serwer WWW postawiony w serwisie mintshost.pl. Wszystko sprawnie i ok, do pory instalacji CMS'a. W tabelce instalatora wyskoczył chamski "X" z powodem "MySQL support must be enabled in PHP". Problem jest w tym, że nie nie wiem gdzie znajduje się plik php.ini na moim serwerze i jaka funkcja w tej konfiguracji za tym stoi. Może ktoś z was miał ten sam problem?

 

Za wszelkie odpowiedzi dziękuje :wub:

 

@Edit:
Jeśli napisałem w złym dziale to przeniosę. ;)

Edytowano przez Wonszur (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Jeżeli chodzi o hosting www to dostęp ma tylko administrator serwera. Jeżeli chodzi o vps/dedyk to /etc/php.ini

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Mintshost podaje że dla hostingu WWW dostęp do PHP.ini masz poprzez Direct Admin.

 

Z tym, że ja nie znam hostingu w którym MySQL nie byłby domyślnie dostępny w PHP.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Po pierwsze sprawdź w phpinfo() czy masz włączony MySQL.

 

Jeśli nie to sprawdź czy masz w php.ini (albo w innych opcjach ) zaznaczone moduły z MySQL. Np. w DirectAdmin w hekko.pl jest to w "Ustawienia globalne PHP". W szczególności interesują cię: mysql, mysqli, mysqlnd i być może pdo_mysql.

 

Jak dalej nie masz obsługi MySQL to wal do obsługi mintshost.pl i niech naprawiają.

 

Po drugie jeśli MySQL w PHP jest włączony (a na 99% zakładam, że jest) to problemu szukaj raczej w skrypcie. Tutaj już nie pomogę. Aby sprawdzić czy wszystko działa możesz wystartować coś innego np. Wordpress - jak i tam się wykrzacza wal do obsługi.

 

PS. Nie wiem jakiego dokładnie modułu potrzebuje Xibo Open Source Digital, ale jeśli przestarzałego, podstawowego "mysql" to o ile pamięć mnie nie myli jest już niedostępny w PHP 7. Jeśli masz taki ustawiony to zmieniaj wersję PHP i za każdym razem sprawdzaj jakie moduły MySQL są załadowane. Spróbuj odpalić Xibo na takiej wersji dla której masz wszystkie moduły mysql (czyli: mysql, mysqli, mysqlnd i pdo_mysql). Proponuję zacząć od PHP 5.3, piąć się po kolei przez 5.4, 5.5, 5.6, 7 i zatrzymać się na najnowszej która działa.

Edytowano przez nnd_newbie (zobacz historię edycji)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się


×