Skocz do zawartości


 

Zdjęcie

Konfiguracja Virtualhosta dla domeny pod apache2 i ngnix

Konfiguracja Virtualhosta dla domeny pod apache2 i ngnix

  • Proszę się zalogować aby odpowiedzieć
3 odpowiedzi na ten temat

Konfiguracja Virtualhosta dla domeny pod apache2 i ngnix

#1 R@fi

R@fi

    Rafi

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1231 postów

Napisany 21 październik 2017 - 11:17

Witajcie mam taki problem mianowicie nie wiem dlaczego nie startuje mi virtualhost dla nowej domeny mój plik cfg przedstawia sie następująco :

<VirtualHost *:8080>
	ServerName djlive.eu
	ServerName www.djlive.eu

	ServerAdmin kontakt@djlive.eu
	DocumentRoot /var/www/html/djlivepl

	# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
	# error, crit, alert, emerg.
	# It is also possible to configure the loglevel for particular
	# modules, e.g.
	#LogLevel info ssl:warn

	<Directory "/var/www/html/djlivepl">
		AllowOverride All
		Options -Indexes
	</Directory>
	ErrorLog ${APACHE_LOG_DIR}/error-djlivepl.log
	CustomLog ${APACHE_LOG_DIR}/access-djlivepl.log combined
</VirtualHost>
<VirtualHost *:8080>
	ServerName api.djlive.eu

	ServerAdmin kontakt@djlive.eu
	DocumentRoot /var/www/html/djliveeu/api

	# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
	# error, crit, alert, emerg.
	# It is also possible to configure the loglevel for particular
	# modules, e.g.
	#LogLevel info ssl:warn

	<Directory "/var/www/html/djliveeu/api">
		AllowOverride All
		Options -Indexes
	</Directory>
	ErrorLog ${APACHE_LOG_DIR}/error-djliveeu-api.log
	CustomLog ${APACHE_LOG_DIR}/access-djliveeu-api.log combined
</VirtualHost>

i ngnix

proxy_cache_path /tmp/nginx levels=1:2 keys_zone=static:10m inactive=4h max_size=1g;
#proxy_cache_key "$request_method$host$request_uri";
server {
	listen   80; 
	listen 443 ssl;
	include ssl-djliveeu;

	gzip on;
	gzip_disable "msie6";

	gzip_vary on;
	gzip_proxied any;
	gzip_comp_level 6;
	gzip_buffers 16 8k;
	gzip_types text/plain text/css application/json application/x-javascript application/javascript text/xml application/xml application/xml+rss text/javascript;
	
	root /var/www/html/djliveeu; 
	index index.php index.html;

	server_name djlive.eu api.djlive.eu app.djlive.eu; 

	#location / {
		#proxy_set_header X-Real-IP  $remote_addr;
		#proxy_set_header X-Forwarded-For $remote_addr;
		#proxy_set_header Host $host;
		#proxy_pass http://127.0.0.1:8080;
	#}
	#location /ajax/chat {
		#fastcgi_pass 127.0.0.1:9000;
		#include fastcgi.conf;
	#}
	location = /ajax/chat/chatMessages.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	#rewrite ^/v2/(.*)/streamInfo$ /api/v2/stream.php?name=$1 last;
	#location = /api/v2/stream.php {
		#fastcgi_pass unix:/var/run/php5-fpm.sock;
		#include fastcgi.conf;
	#}
	location = /ajax/stream/viewers.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	location = /ajax/privatemessages/getUnreadMessages.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	location = /ajax/privatemessages/getMessagesList_html.php {
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		include fastcgi.conf;
	}
	#location = /ajax/stream/viewers.php {
	#	fastcgi_pass unix:/var/run/php5-fpm.sock;
	#	include fastcgi.conf;
	#}
	location /.well-known {
		alias /var/www/html/djliveeu/.well-known;
	}
	location /nginx-status {
		stub_status on;
		access_log off;
	}
	location ~* \.(eot|ttf|woff|woff2)$ {
		add_header Access-Control-Allow-Origin *;
	}
	location / {
		try_files $uri @proxy;
	}
	location ~* \.(js|css|jpg|jpeg|gif|png|svg|ico|pdf|html|htm)$ {
		expires      14d;
#		proxy_pass http://127.0.0.1:8080;
#		proxy_set_header Host $host;
#		proxy_cache static;
#		proxy_cache_valid 200 1d;
#		add_header X-Proxy-Cache $upstream_cache_status;
	}
	location @proxy {
		proxy_pass http://127.0.0.1:8080;
		include /etc/nginx/proxy_params;
	}
	location ~* \.php$ {
		proxy_pass http://127.0.0.1:8080;
		fastcgi_buffers 16 16k; 
		fastcgi_buffer_size 32k;
		include /etc/nginx/proxy_params;
	}
	location ~ /\.ht {
		deny all;
	}
}
server {
	listen   80; 
	listen 443 ssl;
	include ssl-djliveeu;
	server_name www.djlive.eu; 
	return 301 https://djlive.eu$request_uri;
}
server {
	listen   80; 
	listen 443 ssl;
	include ssl-djliveeu;


	#root /var/www/html/djliveeu; 
	index index.php index.html;

	server_name live.djlive.eu sys.djlive.eu edge.live.djlive.eu v1.djlive.eu v.djlive.eu edge.preview.djlive.eu live-hls.djlive.eu stream_main.sterowanie24.pl; 
	location /.well-known {
		alias /var/www/html/djliveeu/.well-known;
	}

	location / {
		proxy_set_header X-Real-IP  $remote_addr;
		proxy_set_header X-Forwarded-For $remote_addr;
		proxy_set_header Host $host;
		proxy_set_header REMOTE_ADDR $remote_addr;
		proxy_pass http://10.94.94.101:80;
	}
	location ~ /\.ht {
		deny all;
	}
}
server {
	listen   80; 
	listen 443 ssl http2;
	include ssl-djliveeu;

	location /.well-known {
		alias /var/www/html/djliveeu/.well-known;
	}

	#root /var/www/html/djliveeu; 
	index index.php index.html;

	server_name img.djlive.eu; 

	location /preview {
		proxy_set_header X-Real-IP  $remote_addr;
		proxy_set_header X-Forwarded-For $remote_addr;
		proxy_set_header Host $host;
		proxy_set_header REMOTE_ADDR $remote_addr;
		proxy_pass http://10.94.94.101:80;
	}
	location ~ /\.ht {
		deny all;
	}
}

Problem w tym że po wpisaniu adresu www.djlive.eu zgłasza się standardowa deafultowa strona i nie mam pomysłu jak temu zaradzić

 

prosze o pomoc


  • 0

#2 zderki

zderki

    Czasami na forum

  • WHT Pro
  • 49 postów
  • Skąd:Rzeszów
  • Firma:prog-res

Napisany 22 październik 2017 - 10:10

Po kolei: apache mas ustawiony na nasłuchiwanie porcie 8080 (kwestia czy masz ten port odpalony w ports.conf), strona html jaka sie odpala to strona defaultowa dla apache nie dla nginxa.

<VirtualHost *:8080> zmień na <VirtualHost *:80>  (na <VirtualHost *:443> dla ssl - chyba ze uzywasz letsencrypta, certbot sam wszystko wtedy zrobi za ciebie ;))

 

ps. na 8080 nasłuchuje ci nginx


Edytowany przez zderki, 22 październik 2017 - 10:12.

  • 0

#3 R@fi

R@fi

    Rafi

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1231 postów

Napisany 22 październik 2017 - 14:12

Po kolei: apache mas ustawiony na nasłuchiwanie porcie 8080 (kwestia czy masz ten port odpalony w ports.conf), strona html jaka sie odpala to strona defaultowa dla apache nie dla nginxa.

<VirtualHost *:8080> zmień na <VirtualHost *:80>  (na <VirtualHost *:443> dla ssl - chyba ze uzywasz letsencrypta, certbot sam wszystko wtedy zrobi za ciebie ;))

 

ps. na 8080 nasłuchuje ci nginx

 

Dodałem port 8081

 

plik ports.conf 

 

wygląda tak

  GNU nano 2.2.6                                                              File: /etc/apache2/ports.conf

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 8080
Listen 8081

<IfModule ssl_module>
        Listen 8443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 8443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

a virtualhost zmieniłem na <VirtualHost *:8081>

 

 uzywam letsencrypta, 


  • 0

#4 R@fi

R@fi

    Rafi

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1231 postów

Napisany 23 październik 2017 - 20:44

Czy ktos mi pomoże ?


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników