Skocz do zawartości


 

Zdjęcie

problematyczna propagacja dns

problematyczna propagacja dns

  • Proszę się zalogować aby odpowiedzieć
11 odpowiedzi na ten temat

problematyczna propagacja dns

#1 att

att

    Nowy użytkownik

  • Nowy
  • 6 postów

Napisany 07 wrzesień 2017 - 05:21

Dzień dobry,

Problem dotyczy domeny szczecina.pl. Domena jest w hekko.

Dotychczasowe serwery dns to ns1.hekko.net.pl i ns2.hekko.net.pl i wskazywały na ip w 1and1.

Jako, że 1and1 wypowiedziało umowę zamówiłem vps+plesk w home.pl. Mój admin stwierdził, że prościej mu będzie zarządzać wszystkim w plesku. Dlatego w ustawieniach dns w hekko wpisał nowe serwery ns1.szczecina.pl i ns2.szczecina.pl oraz przypisał im IP serwera w home.pl

 

Przez kilka godzin po wpisaniu w przeglądarkę adresu szczecina.pl lądowałem na "starym" serwerze. A potem już "nigdzie".  I ten stan trwa 2 doby. Nowy adres IP to .46.41.135.31. Ping dochodzi. Ale do szczecina.pl już nie - "Żądanie polecenia ping nie może znaleźć hosta szczecina.pl. Sprawdź nazwę i ponów próbę."

 

Serwisy

http://www.digwebint...ll&nameservers=

czy np.

https://dnschecker.o...NS/szczecina.pl

pokazują, że coś jest źle, chociaż niektóre niby już działają.

 

Ten stan trwa już 2 i pół doby.

 

Pytanie - co robić? Czekać? Czy wykonać jakieś ruchy i czekać od nowa? A jeśli ruchy to jakie?

 

Jako ciekawostka - podobna operacja została rozpoczęta kilka minut później (burg.com.pl / ns1/ns2.burg.com.pl) odbyła się płynnie, bezboleśnie i zamknęła się w kilku godzinach.


Edytowany przez att, 07 wrzesień 2017 - 05:22.

  • 0

#2 Ciacho

Ciacho

    Nowy użytkownik

  • Użytkownicy
  • 4 postów

Napisany 07 wrzesień 2017 - 05:49

Za whois:

serwery nazw:
ns1.szczecina.pl. [8.8.8.8]
ns2.szczecina.pl. [8.8.4.4]

Rekordy glue dla dnsów mają nieprawidłowy adres IP - powinny wskazywać na realny serwer DNS dla domeny a nie na recursywne DNS google. Czyli w skrócie - popraw ustawienia domeny u rejestratora.


  • 0

#3 att

att

    Nowy użytkownik

  • Nowy
  • 6 postów

Napisany 07 wrzesień 2017 - 06:31

U rejestratora, a dokładniej w hekko.pl jest tak, jak w załączniku.

Załączony plik  hekko.jpg   28,69K   4 pobrań

 

A w BOK hekko spuścili mnie na drzewo i sugerowali błędną konfigurację DNS w home.pl.

Mimo, że intuicja mi podpowiada, że nie mają racji, bo świat nawet jeszcze nie wie, że ma szukać dnsa w home.

 

Słowem, poprawić nie umiem, bo w hekko drugi raz się nie da wysłać zmiany IP.


  • 0

#4 Ciacho

Ciacho

    Nowy użytkownik

  • Użytkownicy
  • 4 postów

Napisany 07 wrzesień 2017 - 06:47

1. Ustawienie obu dns na jednym IP - to proszenie się o awarię (da się z tym żyć ale nie jest to praktykowane)

2. Zmień rejestratora

3. Przeklej im wynik z whois (https://www.dns.pl/cgi-bin/whois.pl) - bo jak byk mimo że ich panel twierdzi że jest inny adres, to nie jest on prawidłowy

4. Mimo wszystko polecam zmianę rejestratora jak "zmiany są tylko jednorazowe".


  • 0

#5 att

att

    Nowy użytkownik

  • Nowy
  • 6 postów

Napisany 07 wrzesień 2017 - 07:28

Jeśli chodzi o 1) to właśnie się o tym dowiedziałem i gdy tylko ogarnę bieżące zagadnienia związane z przenosinami to się tym zajmę.

 

Ad 3) zgłaszając problem podałem im link https://intodns.com/szczecina.pl, a tam jak wół stoi:

 

      Parent        Domain NS records            Nameserver records returned by the parent servers are:

                                                                   ns2.szczecina.pl.   ['8.8.4.4']   [TTL=86400]
                                                                   ns1.szczecina.pl.   ['8.8.8.8']   [TTL=86400]
                                                                   a-dns.pl was kind enough to give us that information.

 

     ale tak jak pisałem, spuścili mnie na drzewo i kazali szukać błędów w home.pl.

     Ale ponownie za moment zadzwonię. Postaram się być uprzejmy.

 

Ad 2) i 4)

to już 4 faul ze strony hekko w ogóle, a drugi ciężki. I jestem przekonany, że nie pozostanę ich klientem ponad bieżący okres.

Tym niemniej zmiana rejestratora przy 15 czy 20 domenach to kolejne kłopoty i trzeba się do tego przygotować. A teraz muszę znaleźć bieżące, doraźne rozwiązanie.

 

 


  • 0

#6 home.pl

home.pl

    Stały użytkownik

  • Firma Bronze
  • PipPipPipPipPip
  • 127 postów
  • Firma:home.pl

Napisany 07 wrzesień 2017 - 07:43

Czy po stronie VPSa na pewno utworzyłeś strefę DNS dla tej domeny? Jeżeli korzystasz z PLESKa to musisz dodać nowy webspace z tą domeną z szablonu który zaproponuje Plesk. Poczekaj wówczas kilka minut i skieruj domenę na właściwe serwery DNS utworzone właśnie na tym VPS wraz z podaniem adresu IP serwera. Być może przez brak webspace'a i strefy robi się mętlik i cały czas zewnętrzne narzędzia widzą adresy IP z DNS google.


  • 0

#7 att

att

    Nowy użytkownik

  • Nowy
  • 6 postów

Napisany 07 wrzesień 2017 - 08:47

Wydaje mi się, że tak:

Załączony plik  homewebspace.jpg   86,79K   4 pobrań

 


  • 0

#8 att

att

    Nowy użytkownik

  • Nowy
  • 6 postów

Napisany 07 wrzesień 2017 - 10:38

Porównałem na tyle ile mogłem logi z czynności w hekko i w home i z dużą dozą pewności mogę powiedzieć, że webspace był już 30 sierpnia. Przeglądałem nawet strony używając zmyłki za pomocą edycji pliku hosts, a admin wysłał i odebrał maila tą metodą.

Natomiast zmiana DNS W hekko miała miejsce dopiero 4 września.

 

A ja dalej w czarnej....


  • 0

#9 nnd_newbie

nnd_newbie

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 156 postów

Napisany 07 wrzesień 2017 - 11:11

Porównałem na tyle ile mogłem logi z czynności w hekko i w home i z dużą dozą pewności mogę powiedzieć, że webspace był już 30 sierpnia. Przeglądałem nawet strony używając zmyłki za pomocą edycji pliku hosts, a admin wysłał i odebrał maila tą metodą.
Natomiast zmiana DNS W hekko miała miejsce dopiero 4 września.
 
A ja dalej w czarnej....

I słusznie że hekko zwala na home, bo jeśli strefa DNS nie jest u nich to co oni mają do poprawnego rozwiązywania nazw ns1 i ns2.szczecina.pl? A te ewidentnie wskazują na DNS Googla. Ściągnij tego informatyka co ci doradza i niech on to wyjaśnia.

Albo zaoraj wszystko. Przenieś domenę do OVH i zacznij od początku

Edytowany przez nnd_newbie, 07 wrzesień 2017 - 11:15.

  • 0

#10 Gość_mariaczi_*

Gość_mariaczi_*
  • Goście

Napisany 07 wrzesień 2017 - 11:31

@att, odezwij się na PW i postaram się pomóc.


  • 0

#11 Ciacho

Ciacho

    Nowy użytkownik

  • Użytkownicy
  • 4 postów

Napisany 07 wrzesień 2017 - 12:14

I słusznie że hekko zwala na home, bo jeśli strefa DNS nie jest u nich to co oni mają do poprawnego rozwiązywania nazw ns1 i ns2.szczecina.pl? A te ewidentnie wskazują na DNS Googla. Ściągnij tego informatyka co ci doradza i niech on to wyjaśnia.


 
Co hekko ma do rekordów ns1/ns2.szczecina.pl - rekordy glue.
Po stronie serwera home - ma w porządku:

host -t ns szczecina.pl 46.41.135.31
Using domain server:
Name: 46.41.135.31
Address: 46.41.135.31#53
Aliases: 
 
szczecina.pl name server ns1.szczecina.pl.
szczecina.pl name server ns2.szczecina.pl.
[...]
ns1.szczecina.pl has address 46.41.135.31
[...]
ns2.szczecina.pl has address 46.41.135.31


Edytowany przez Ciacho, 07 wrzesień 2017 - 12:15.

  • 0

#12 att

att

    Nowy użytkownik

  • Nowy
  • 6 postów

Napisany 07 wrzesień 2017 - 14:02

Dziękuję wszystkim za pomoc.

Kolega mariaczi zaproponował mi obejście za pomocą freedns.42.pl/ i przeprowadził za rękę.

 

Teraz na spokojnie będę musiał wdrożyć sugestie kolegi Ciacho.

 

Pozostaje jednak pytanie, co, qfa, poszło nie tak i jak temu zapobiec w przyszłości...

 

 

 


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników