Skocz do zawartości


 

Zdjęcie

TLS handshake z .... <- czasem baaaardzo długo...

TLS handshake z .... <- czasem baaaardzo długo...

  • Proszę się zalogować aby odpowiedzieć
5 odpowiedzi na ten temat

TLS handshake z .... <- czasem baaaardzo długo...

#1 Rysiu512

Rysiu512

    Czasami na forum

  • Użytkownicy
  • 42 postów
  • Imię:Lukasz

Napisany 06 wrzesień 2017 - 09:14

Mam problem. Nie wiedziałem za bardzo gdzie dodać wątek więc dodaję tutaj.

 

Mam serwerek. VPS. Na nim certyfikat Let's Encrypt.

 

Czasem strasznie długo potrafi mi się ładować strona na etapie "TLS handshake z ...".

Nie zdarza się to często ale raczej sporadycznie, a jednak...

 

Konsola w tym momencie działa bardzo dobrze - wariuje tylko strona po SSL.

Load wynosi 0.00 <- chyba nawet może być tak, że jestem sam na stronie.

 

W czym może tkwić problem?


  • 0

#2 Rysiu512

Rysiu512

    Czasami na forum

  • Użytkownicy
  • 42 postów
  • Imię:Lukasz

Napisany 06 wrzesień 2017 - 10:55

Coś jest ostro nie tak:

 

Tutaj przykładowy przebieg:

 

Wystarczy zerknąć na SSL:

 

Test robiony na https://www.webpagetest.org

 

waterfall.png


  • 0

#3 Rysiu512

Rysiu512

    Czasami na forum

  • Użytkownicy
  • 42 postów
  • Imię:Lukasz

Napisany 06 wrzesień 2017 - 12:56

Oj widzę, że może być marnie z pomocą...

 

Kolejny dowód na problem (dodatek do Chrome analizujący czasy):

 

21392803_1551937664871610_570007635_o.pn

 

 

Szukałem w necie odpowiedzi - nie znalazłem.


  • 0

#4 maniektme

maniektme

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 275 postów
  • Skąd:Szczecin
  • Imię:Mariusz
  • Nazwisko:Szafran

Napisany 06 wrzesień 2017 - 17:04

Podaj adres strony to będzie łatwiej ocenić.

 

Druga sprawa to jaki masz klucz prywatny(4096-bit, więcej)?

Poza tym co masz za HTTP na tym VPSie? Masz Apache? To włącz sobie mod_status - coś pozwoli Ci bardziej prześledzić HTTP.

 

Może coś ładujsze z zewnątrz(spoza swojego VPS) po SSL i tutaj jest wąskie gardło?


  • 0

#5 Rysiu512

Rysiu512

    Czasami na forum

  • Użytkownicy
  • 42 postów
  • Imię:Lukasz

Napisany 06 wrzesień 2017 - 19:35

Sprawa trudna.

Nic nie ładuję kompletnie z zewnątrz,

Wszystko idle.

 

Problem jednak rozwiązałem.

Testowałem różne TLS: TLSv1.2, TLSv1.1, TLSv1 <- zawsze ten sam problem.

 

Zmieniłem jednak KeepAlive na "Off" i zaczęło śmigać...

Wiem, że powinno być teoretycznie wolniej ale wyszło na to, że przyśpieszyło.

 

Napisałem na stackoverflow.

Tam mi jednak napisali, że to normalne, że strona po SSL działa wolniej niż po czystym HTTP.

Napisałem, że całość mam na PHP5 to napisali, że tym bardziej będzie działać wolno bo to musi być przecież PHP7.

Kiedy napisałem, że to nie wina PHP bo odpalanie "blank page" *albo z jednym echo) zajmuje mi czasem ponad 60 sekund to napisali mi, że to kwestia serwera, bo przecież to jest VPS a nie dedicated, a to, że strona z jednym echo ładuje mi się 60 sekund to przecież normalne bo na VPS nie mam gwarantowanego procesora ani RAM'u.

Ogólnie szkoda gadać....

 

Udało mi się na szczęście "jakoś" rozwiązać problem.

Już faktycznie w głowę zachodziłem czy faktycznie za mało pamięci ma mój VPS aby szybciej niż 60 sekund wypisać jedno echo. A może to procesor? :(


  • 0

#6 Gość_marder_*

Gość_marder_*
  • Goście

Napisany 18 wrzesień 2017 - 20:53

Napisałem, że całość mam na PHP5 to napisali, że tym bardziej będzie działać wolno bo to musi być przecież PHP7.
Kiedy napisałem, że to nie wina PHP bo odpalanie "blank page" *albo z jednym echo) zajmuje mi czasem ponad 60 sekund to napisali mi, że to kwestia serwera, bo przecież to jest VPS a nie dedicated, a to, że strona z jednym echo ładuje mi się 60 sekund to przecież normalne bo na VPS nie mam gwarantowanego procesora ani RAM'u.
Ogólnie szkoda gadać....

 
Miewam podobne atrakcje na serwerze dedykowanym. Raczej nie jest to kwestia braku zasobów (RAM i procesor), bo to co jest na tym serwerze nie wykorzystuje ich w pełni.
 

Zmieniłem jednak KeepAlive na "Off" i zaczęło śmigać...

 

U mnie nie pomogło. Będę próbował to rozgryźć, jeśli mi się uda, napiszę o tym.


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników