Skocz do zawartości


 

Zdjęcie

Upgrade do Debian 9

Upgrade do Debian 9

  • Proszę się zalogować aby odpowiedzieć
12 odpowiedzi na ten temat

Upgrade do Debian 9

#1 karkow

karkow

    Często na forum

  • Użytkownicy
  • 57 postów

Napisany 20 lipiec 2017 - 22:01

Hej.

 

Mając dwa w zasadzie identyczne vps (kvm) z Debianem 8 zrobiłem upgrade do 9 na zasadzie:

 

- edycja source.list (podmiana wpisów z jessie na stable)

- apt-get update & upgrade & dist-upgrade i reboot

 

Na pierwszym vps mam info że:  

3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u2 (2017-06-26) x86_64

A drugi :  

4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) x86_64

Ponowne apt-get update & upgrade nic nie znajduje. Dlaczego różnią się kernelem?


Edytowany przez karkow, 20 lipiec 2017 - 22:02.

  • 0

#2 Gość_patrys_*

Gość_patrys_*
  • Goście

Napisany 21 lipiec 2017 - 06:47

apt-cache showpkg linux-image-amd64 && dpkg --list | grep linux-image

  • 0

#3 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 21 lipiec 2017 - 08:20

Dlaczego różnią się kernelem?

Debian 9 jest obsługiwany przez tą wersje domyślnie. Porzucili wsparcie dla 3.16.


  • 0

#4 MateuszCODE

MateuszCODE

    Stały użytkownik

  • WHT Pro
  • PipPipPipPipPip
  • 214 postów
  • Skąd:Polska

Napisany 21 lipiec 2017 - 09:58

Spróbuj ręcznie zainstalować Kernel jeżeli masz dodany stretch-backports apt -t stretch-backports install linux-image-amd64

Edytowany przez MateuszCODE, 21 lipiec 2017 - 10:00.

  • 0

#5 WireBoot

WireBoot

    Czasami na forum

  • Użytkownicy
  • 39 postów

Napisany 21 lipiec 2017 - 10:09

Możliwe że miałeś paczkę kernela jako "hold"

apt-mark showhold

 

Zobacz czy przypadkiem nie jest własnie zablokowany przed aktualizacjami.


  • 0

#6 karkow

karkow

    Często na forum

  • Użytkownicy
  • 57 postów

Napisany 21 lipiec 2017 - 13:47

apt-cache showpkg linux-image-amd64 && dpkg --list | grep linux-image

Package: linux-image-amd64
Versions:
4.9+80 (/var/lib/apt/lists/deb.debian.org_debian_dists_stable_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/deb.debian.org_debian_dists_stable_main_binary-amd64_Packages
                  MD5: 273d1b43f376fdf9893fad396f2ed5f1
 Description Language: en
                 File: /var/lib/apt/lists/deb.debian.org_debian_dists_stable_main_i18n_Translation-en
                  MD5: 273d1b43f376fdf9893fad396f2ed5f1


Reverse Depends:
  xen-linux-system-amd64,linux-image-amd64
Dependencies:
4.9+80 - linux-image-4.9.0-3-amd64 (0 (null))
Provides:
4.9+80 - linux-latest-modules-4.9.0-3-amd64 (= )
Reverse Provides:
ii  linux-image-3.16.0-4-amd64     3.16.43-2+deb8u2               amd64        Linux 3.16 for 64-bit PCs
ii  linux-image-4.9.0-3-amd64      4.9.30-2+deb9u2                amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-amd64              4.9+80                         amd64        Linux for 64-bit PCs (meta-package)

apt-mark showhold - nie zwraca nic.

 

Ręcznie próbowałem tylko:

apt-get install --reinstall linux-image-4.9.0-3-amd64

Ale po reboocie dalej stary kernel.


Edytowany przez karkow, 21 lipiec 2017 - 13:53.

  • 0

#7 WireBoot

WireBoot

    Czasami na forum

  • Użytkownicy
  • 39 postów

Napisany 21 lipiec 2017 - 13:52

Wygląda na to że ustawiony jest grub aby system "startował" z starszego jądra

co jest ustawione tu:

grep GRUB_DEFAULT /etc/default/grub

?

 

Jesli cos innego niz 0 to ustaw na 0, a następnie

update-grub2

 

i restart serwera.


Edytowany przez WireBoot, 21 lipiec 2017 - 13:53.

  • 0

#8 karkow

karkow

    Często na forum

  • Użytkownicy
  • 57 postów

Napisany 21 lipiec 2017 - 13:57

Nie ma takiego pliku ani katalogu...

Nie ma gruba w tym katalogu.


Edytowany przez karkow, 21 lipiec 2017 - 13:58.

  • 0

#9 karkow

karkow

    Często na forum

  • Użytkownicy
  • 57 postów

Napisany 21 lipiec 2017 - 20:18

Być może jest to problem z grub. Nie mam katalogów: /etc/grub.d/ oraz /etc/default/grub.

 

I jeszcze jedna różnica:

ls /boot

config-3.16.0-4-amd64  initrd.img-3.16.0-4-amd64  System.map-4.9.0-3-amd64
config-4.9.0-3-amd64   initrd.img-4.9.0-3-amd64   vmlinuz-3.16.0-4-amd64
extlinux               System.map-3.16.0-4-amd64  vmlinuz-4.9.0-3-amd64
ls /boot

config-3.16.0-4-amd64  initrd.img-3.16.0-4-amd64  System.map-4.9.0-3-amd64
config-4.9.0-3-amd64   initrd.img-4.9.0-3-amd64   vmlinuz-3.16.0-4-amd64
grub                   System.map-3.16.0-4-amd64  vmlinuz-4.9.0-3-amd64

Edytowany przez karkow, 21 lipiec 2017 - 20:24.

  • 0

#10 WireBoot

WireBoot

    Czasami na forum

  • Użytkownicy
  • 39 postów

Napisany 21 lipiec 2017 - 21:06

Możliwe że masz lilo jako podstawowy bootloader

 

Co pokazuje to:

dpkg -l|egrep "grub|lilo"

 

Jeśli nie będzie ani LILO ani GRUB to upewnij sie ze na pewno masz VPS KVM  :)

 

W przypadku gdy lilo będzie obecne w twoim systemie, sa dwie opcje:

Pierwsza - Poprawienie konfiguracji lilo:

https://wiki.debian.org/LILO

 

Druga - usuniecie lilo i ustawaienie GRUB do głównego sektora rozruchowego

apt-get remove lilo

apt-get install grub-pc

update-grub2

grub-install /dev/sdX

 

gdzie /dev/sdX to nazwa partycji w systemie (mozna sprawdzić nazwy np w fdisk -l )

 

Z pierwszą jak i drugą opcja nalezy postępować z rozwagą, błędna konfiguracja może spowodować _NIE_URUCHOMIENIE_SIĘ żadnego jądra, co skutkuje nie uruchomienie się systemu.

 

 


  • 0

#11 karkow

karkow

    Często na forum

  • Użytkownicy
  • 57 postów

Napisany 21 lipiec 2017 - 23:00

To vps z ovh więc kvm.

 

dpkg -l|egrep "grub|lilo" - nie zwraca wyników

 

Być może coś podczas upradu? Nie zgodziłem się na zmianę konfiguracji jakiegoś pliku lub coś...

Serwer działa normalnie w zasadzie mi to nie przeszkadza ale niesmak pozostał :D

 

/edit

WireBoot mnie natchnął... mam extlinux jako bootloader. 


Edytowany przez karkow, 21 lipiec 2017 - 23:06.

  • 0

#12 WireBoot

WireBoot

    Czasami na forum

  • Użytkownicy
  • 39 postów

Napisany 22 lipiec 2017 - 07:37

Spróbuj wykonań komendę

extlinux-update

 


  • 0

#13 karkow

karkow

    Często na forum

  • Użytkownicy
  • 57 postów

Napisany 22 lipiec 2017 - 08:52

extlinux --update

Usage: extlinux [options] directory
  --device         Force use of a specific block device (experts only)
  --install    -i  Install over the current bootsector
  --update     -U  Update a previous installation
  --zip        -z  Force zipdrive geometry (-H 64 -S 32)
  --sectors=#  -S  Force the number of sectors per track
  --heads=#    -H  Force number of heads
  --stupid     -s  Slow, safe and stupid mode
  --raid       -r  Fall back to the next device on boot failure
  --once=...   -o  Execute a command once upon boot
  --clear-once -O  Clear the boot-once command
  --reset-adv      Reset auxilliary data
  --menu-save= -M  Set the label to select as default on the next boot

A może podmienić extlinuxa na grub2 ?


Edytowany przez karkow, 22 lipiec 2017 - 08:55.

  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników