Skocz do zawartości


 

Zdjęcie

Proxmox - problem z uruchomieniem maszyny.

Proxmox - problem z uruchomieniem maszyny.

  • Proszę się zalogować aby odpowiedzieć
2 odpowiedzi na ten temat

Proxmox - problem z uruchomieniem maszyny.

#1 GyniO

GyniO

    Stały użytkownik

  • WHT Pro
  • PipPipPipPipPip
  • 307 postów

Napisany 31 maj 2017 - 16:04

Hej, mam problem z VPS'em na proxmoxie:

 

Maszyna działała przez 2 miesiące - wszystko grało, aż do momentu gdy padł mysql / php - nie można było zapisywać nic na serwerze po sftp - zmiana konfigów itd - ani restartować usługi. 

 

Zrobiłem reboota, ale maszyna już nie wstała, po zalogowaniu do proxmoxa pojawił się błąd:

 

Task viewer: CT 102 - Uruchom Wyjście Status Zatrzymaj Job for lxc@102.service failed. See 'systemctl status lxc@102.service' and 'journalctl -xn' for details. TASK ERROR: command 'systemctl start lxc@102' failed: exit code 1

 

 
 
Task viewer: CT 102 - Uruchom
 
Job for lxc@102.service failed. See 'systemctl status lxc@102.service' and 'journalctl -xn' for details.
TASK ERROR: command 'systemctl start lxc@102' failed: exit code 1

 

root@s1:~# systemctl status lxc@102.service

● lxc@102.service - LXC Container: 102
   Loaded: loaded (/lib/systemd/system/lxc@.service; disabled)
  Drop-In: /usr/lib/systemd/system/lxc@.service.d
           └─pve-reboot.conf
   Active: failed (Result: exit-code) since śro 2017-05-31 16:52:12 CEST; 35s ago
     Docs: man:lxc-start
           man:lxc
  Process: 1481 ExecStart=/usr/bin/lxc-start -n %i (code=exited, status=1/FAILURE)
 
maj 31 16:51:59 s1 systemd[1]: Starting LXC Container: 102...
maj 31 16:52:12 s1 lxc-start[1481]: lxc-start: tools/lxc_start.c: main: 366 The container failed to start.
maj 31 16:52:12 s1 lxc-start[1481]: lxc-start: tools/lxc_start.c: main: 368 To get more details, run the container in foreground mode.
maj 31 16:52:12 s1 lxc-start[1481]: lxc-start: tools/lxc_start.c: main: 370 Additional information can be obtained by setting the --logfile ... options.
maj 31 16:52:12 s1 systemd[1]: lxc@102.service: control process exited, code=exited status=1
maj 31 16:52:12 s1 systemd[1]: Failed to start LXC Container: 102.
maj 31 16:52:12 s1 systemd[1]: Unit lxc@102.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
 

 

root@s1:~# journalctl -xn

-- Logs begin at śro 2017-05-31 16:51:17 CEST, end at śro 2017-05-31 16:53:04 CEST. --
maj 31 16:52:12 s1 systemd[1]: Starting Update UTMP about System Runlevel Changes...
-- Subject: Unit systemd-update-utmp-runlevel.service has begun with start-up
-- Defined-By: systemd
--
-- Unit systemd-update-utmp-runlevel.service has begun starting up.
maj 31 16:52:12 s1 systemd[1]: Started Update UTMP about System Runlevel Changes.
-- Subject: Unit systemd-update-utmp-runlevel.service has finished start-up
-- Defined-By: systemd
--
-- Unit systemd-update-utmp-runlevel.service has finished starting up.
--
-- The start-up result is done.
maj 31 16:52:12 s1 systemd[1]: Startup finished in 44.186s (kernel) + 55.593s (userspace) = 1min 39.779s.
-- Subject: System start-up is now complete
-- Defined-By: systemd
--
-- All system services necessary queued for starting at boot have been
-- successfully started. Note that this does not mean that the machine is
-- now idle as services might still be busy with completing start-up.
--
-- Kernel start-up required 44186577 microseconds.
--
-- Initial RAM disk start-up required INITRD_USEC microseconds.
--
-- Userspace start-up required 55593309 microseconds.
maj 31 16:52:18 s1 systemd-timesyncd[636]: Using NTP server [2001:41d0:a:1011::1]:123 (2.debian.pool.ntp.org).
maj 31 16:52:18 s1 systemd-timesyncd[636]: interval/delta/delay/jitter/drift 64s/-0.007s/0.002s/0.000s/+0ppm
maj 31 16:52:34 s1 sshd[1606]: Accepted password for root from xxxxxxxxx port 54713 ssh2
maj 31 16:52:34 s1 sshd[1606]: pam_unix(sshd:session): session opened for user root by (uid=0)
maj 31 16:53:01 s1 CRON[1629]: pam_unix(cron:session): session opened for user root by (uid=0)
maj 31 16:53:01 s1 CRON[1630]: (root) CMD (/usr/local/rtm/bin/rtm 4 > /dev/null 2> /dev/null)
maj 31 16:53:04 s1 CRON[1629]: pam_unix(cron:session): session closed for user root
 

 

Nie mogę odpalić maszyny - ktoś może spotkał taki problem?

Proxmox Virtual Environment 4.4-13


Edytowany przez GyniO, 31 maj 2017 - 16:05.

  • 0

#2 Gość_mariaczi_*

Gość_mariaczi_*
  • Goście

Napisany 31 maj 2017 - 21:36

Zerkałeś czy w logach nie ma więcej informacji? Spróbuj uruchomić ten kontener z palca a opcją "--logfile".

Sprawdź też, czy czasem system plików się nie posypał.


Edytowany przez mariaczi, 31 maj 2017 - 21:38.

  • 0

#3 SiXwishlist

SiXwishlist

    Freedom Forever

  • Firma Bronze
  • PipPipPipPipPipPipPipPip
  • 2366 postów
  • Skąd:Great Britain
  • Firma:SiXwishlist

Napisany 31 maj 2017 - 21:57

backup? 


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników