Skocz do zawartości


 

Zdjęcie

PHP 5.6 na serwerze ze starym DirectAdminem

PHP 5.6 na serwerze ze starym DirectAdminem

  • Proszę się zalogować aby odpowiedzieć
2 odpowiedzi na ten temat

PHP 5.6 na serwerze ze starym DirectAdminem

#1 mk2

mk2

    Nowy użytkownik

  • Nowy
  • 2 postów

Napisany 02 maj 2017 - 20:12

Mam serwer z DirectAdminem 1.45, z tego co rozumiem bez możliwości uaktualnienia bo posiadaczem licencji jest firma hostingowa a nie ja, a nie stać mnie na ani godzinę pracy ich administratora, bo jestem tylko studentem. Chcę uruchamiać skrypty PHP napisane w najnowszych wersjach frameworków, ale ten DirectAdmin ma tylko archaiczne wersje PHP, nie ma 5.6. CustomBuild 2.0 wymaga minimalnie nowszej wersji - 1.46, przez co nie mogę go użyć. CustomBuild 1.2 ma jakiś "php6", przypuszczam że to jest 5.6 ze zmienioną nazwą, chociaż nie mam pewności bo w nazwach plików są jakieś "DEV" wskazujące na to że to wersja niestabilna, ale i tak on się wcale nie kompiluje, wymaga czegoś z OpenSSL-a starszego niż zainstalowany na serwerze, a nie chcę podmieniać plików w /usr/include ani w inny sposób mocno ingerować w system.

 

Wpadłem na pomysł przekopiowania ze zwykłego serwera bez panelu plików PHP 5.6 i wszystkich bibliotek .so.numer_wersji jakie pokaże ldd na tych plikach, skonfigurowałem taki php5-cgi w mod_cgi Apache'a i jakoś to działa, ale to całkowicie pomija DirectAdmina, np. ten pokazuje inną wersję PHP dla domeny, nie może ustawić open_basedir, tylko mogę ja sobie ustawić w php.ini taki sam dla wszystkich domen. Jak w prawidłowy sposób mogę podpiąć PHP 5.6 do DirectAdmina 1.45?

 


  • 0

#2 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 02 maj 2017 - 20:47

Odchodząc nieco od zapytani - jeżeli masz UID I numer licencji to możesz dokonać upgrade samemu. https://help.directa.../item.php?id=29


  • 0

#3 Gość_patrys_*

Gość_patrys_*
  • Goście

Napisany 02 maj 2017 - 21:17

No chyba, że system to np. Debian 6 ;)

 

Nie no 5.6 powinno dać się zbudować nawet na Debianie 6 ( choć nie próbowałem osobiście ).

Ściągnij źródła i skompiluj pod konfiguracje którą masz tak by zastąpić starszą wersje.


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników