Skocz do zawartości


 

Zdjęcie

Apache2 - konfiguracja uprawnień do katalogu

Apache2 - konfiguracja uprawnień do katalogu apache2 virtualhost www-data

  • Proszę się zalogować aby odpowiedzieć
7 odpowiedzi na ten temat

Apache2 - konfiguracja uprawnień do katalogu

#1 radzik

radzik

    Nowy użytkownik

  • Użytkownicy
  • 5 postów

Napisany 26 kwiecień 2017 - 15:52

Witam,

Posiadam serwer z zainstalowanym Debianem 8 plus do tego uruchomione są min. usługi takie jak:

  • apache2
  • mysql (mariadb)
  • php5
  • pureftpd

Borykam się z problemem uprawnień do katalogów dla użytkowników ftp. W tej chwili posiadam dla virtualhosty dla folderów:

  • /var/www/test1.pl/public_html/
  • /var/www/test2.pl/public_html/

oraz użytkowników o tych samych nazwach tj. test1 i test2 z dostępem do w/w folderów.

 

W obu przypadkach dodałem użytkownika www-data do  grup test1, test2 oraz zmieniłem właścicela folderów na www-data:test1, nadając do tego prawa do katalogów 775.

Teoretycznie to teraz działa(czasami :) ) , ale zdaje sobie sprawę, że nie jest to poprawne podejście do tematu.
Z racji niewielkiego doświadczenia z apache, chciałbym dowiedzieć się jak powinienem skonfigurować apache, aby użytkownik ftp i www-data nie mieli problemu z dostępem do plików w danej lokalizacji.

Z góry dziękuję za pomoc.


  • 0

#2 Gość_patrys_*

Gość_patrys_*
  • Goście

Napisany 26 kwiecień 2017 - 16:05

Uruchomić PHP z prawami użytkownika czyli mod_ruid2 lub FPM.


  • 1

#3 radzik

radzik

    Nowy użytkownik

  • Użytkownicy
  • 5 postów

Napisany 27 kwiecień 2017 - 13:59

PHP-FPM to jest to czego szukałem. Dziękuję bardzo.

Niestety mam mały problem. Strony po http, działają prawidłowo. W przypadku przekierowania na https pliki .php nie są przetwarzane tylko się pobierają. Macie jakiś pomysł na to?


  • 0

#4 Gość_patrys_*

Gość_patrys_*
  • Goście

Napisany 27 kwiecień 2017 - 14:28

jakiś błąd w konfiguracji tego virtualhosta z https, z fusów nie wywróżymy ;)


  • 0

#5 radzik

radzik

    Nowy użytkownik

  • Użytkownicy
  • 5 postów

Napisany 27 kwiecień 2017 - 14:49

Już daję plik /etc/apache2/sites-enabled/example.com.conf
 

<VirtualHost *:80>

        ServerName example.com
        ServerName www.example.com
        ServerAdmin webmaster@example.com
        DocumentRoot /var/www/example.com/public_html

   <IfModule mod_fastcgi.c>
        AddType application/x-httpd-fastphp5 .php
        Action application/x-httpd-fastphp5 /php5-fcgi
        Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi-example.com
        FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi-example.com -socket /var/run/php5-fpm-example.com.sock -pass-header Authorization
   </IfModule>

</VirtualHost>

<IfModule mod_ssl.c>
<VirtualHost *:443>

        ServerName example.com
        ServerName www.example.com
        ServerAdmin webmaster@example.com
        DocumentRoot /var/www/example.com/public_html

       <Directory "/var/www/example.com/public_html">
       Order allow,deny
        Allow from all
        AllowOverride All
        </Directory>

        ErrorLog /var/www/example.com/logs/error.log
        CustomLog /var/www/example.com/logs/access.log combined
       
        SSLCertificateFile /etc/letsencrypt/live/example.com/fullchain.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/example.com/privkey.pem
        #Include /etc/letsencrypt/options-ssl-apache.conf

        <IfModule mod_fastcgi.c>
        AddType application/x-httpd-fastphp5 .php
        Action application/x-httpd-fastphp5 /php5-fcgi
        Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi-example.com-ssl
        FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi-example.com-ssl -socket /var/run/php5-fpm-example.com.sock -pass-header Authorization
   </IfModule>

</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
</IfModule>

Wygenerowałem klucze i config za pomocą certbota let's encrypt.
 


  • 0

#6 radzik

radzik

    Nowy użytkownik

  • Użytkownicy
  • 5 postów

Napisany 27 kwiecień 2017 - 21:28

Dodam jeszcze, że wszystko działa prawidłowo z tym samym virtualhostem, gdy włączę standardowy moduł php5. Po przełączeniu na php-fpm znowu się rozsypuję. 


  • 0

#7 Gość_patrys_*

Gość_patrys_*
  • Goście

Napisany 28 kwiecień 2017 - 09:03

Zmień konfiguracje na proxy:

 

<FilesMatch "\.(inc|php)$">
                AddHandler "proxy:unix:/var/run/php5-fpm-example.com.sock|fcgi://localhost" .inc .php
</FilesMatch>

 


  • 0

#8 radzik

radzik

    Nowy użytkownik

  • Użytkownicy
  • 5 postów

Napisany 28 kwiecień 2017 - 11:02

Dziękuję bardzo za Twoją pomoc. Podałem na starcie za mało informacji i ze szklaną kulą ciężko było mi pomóc.

Okazało się, że problem był spowodowany wpisem w .htaccess , który został po stronie przenoszonej z innego hostingu.

AddHandler php7-fastcgi php

Wystarczyło usunąć ten wpis i wszystko działa jak należy. Problem rozwiązany.

Pozdrawiam

 

 


  • 0






Także otagowane jednym lub więcej z tych słów kluczowych: apache2, virtualhost, www-data

0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników