Skocz do zawartości


 

Zdjęcie

Serwer pada co kilka tygodni - zagadka.

Serwer pada co kilka tygodni - zagadka. crash linux freeze centos virtualmin webmin

  • Proszę się zalogować aby odpowiedzieć
20 odpowiedzi na ten temat

Serwer pada co kilka tygodni - zagadka.

#1 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 14:03

Witam,

 

Posiadam serwer dedykowany SoyouStart - 32GB E3-1245v2 SoftRaid 3x120 SSD, pracuje na CentOS 7.3 z panelem Virtualmin.

 

Zainstalowane mam serwery: Apache, MySQL, Postfix, SSH, Dovecot, FTP, firewall CSF, ogólnie to nic więcej, domyślne ustawienia, wszystko default. Mam tylko 8 stron - nie wielkie obciążenie.

 

Raz na kilka tygodni serwer pada! Totalny freeze, tylko restart przez Panel SoYouStart pomaga, gdyż SSH pada także. Po restarcie wszystko wraca do normy i tak przez kolejne 3-4 tygodnie, aż padnie - często w nocy.

 

Hardware, wszystko OK, testowany kilka razy w security mode, wszystko w normie - bez zawieszania. Dodam, że kiedyś miałem ten sam serwer na Debianie i Plesk i takie crash'e się nie zdarzały...

 

Dodam, że CPU pracuje średnio 0,5-1 load. Ram zajęty max 50-60% z 32GB, SSD mniej niż 40% pojemności.

 

Jakieś podpowiedzi, czemu pada? Ostatnie logi wgrałem na stronę, można zobaczyć. Wiele ich nie ma, gdyż zostawiłem kilka linijek przez crashem... PS. adresy IP, zostały lekko zmienione ze względu na klientów dane.

 

Ostatni crash był: Dec 31 01:57:53 z logów nic nie wnioskuje nadzwyczajnego...

 

Jakieś porady? opinie itp. mile widziane.

 

 

Załączone pliki


  • 0

#2 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 14:07

Standard SYS. Tu bym bardziej obstawiał problemy sprzętowe do których OVH zbytnio się nie przyznaje. Miałem to jakiś czas temu to nie wiedzą o co chodzi...


  • 0

#3 Vasthi

Vasthi

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 647 postów

Napisany 31 grudzień 2016 - 14:24

Przejrzyj logi za pomocą 

journalctl _TRANSPORT=kernel -b NUMER_STARTU

Tym listujesz sobie booty

journalctl --list-boot

  • 0

#4 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 14:35

@Roley czyli co? Twój serwer miał tak samo? i uważasz, że to wina sprzętu? No mi się tak nie wydaję, gdyż na innej dystrybucji było OK.

 

@Viperoo te logi także nic nie mówią dlaczego...

 

PS. dodam, że mam custom kernel od OVH. Kiedyś też niby tak miałem i było OK.


  • 0

#5 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 14:47

@Roley czyli co? Twój serwer miał tak samo? i uważasz, że to wina sprzętu? No mi się tak nie wydaję, gdyż na innej dystrybucji było OK.

 

Tak uważam. Ja na swoim jajku tak mam na Debianie. Teraz jest spokój póki co.

 

edit: Spróbuj zrobić swoje jajko i sprawdzisz czy jajko czy sprzęt.


Edytowany przez Rolej, 31 grudzień 2016 - 14:55.

  • 0

#6 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 14:54

 

Tak uważam. Ja na swoim jajku tak mam na Debianie. Teraz jest spokój póki co.
 

 

Czyli na czym jedziesz teraz? Ja zamierzam przejść na Ubuntu, myślałem o Debianie ale Ubuntu ma PHP7 - to co chce. Magento chodzi jak burza na PHP7.


  • 0

#7 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 15:03

 

Czyli na czym jedziesz teraz? Ja zamierzam przejść na Ubuntu, myślałem o Debianie ale Ubuntu ma PHP7 - to co chce. Magento chodzi jak burza na PHP7.

 

Na Debianie też jest PHP7 w dotdeb.org. Spróbuj postawić najnowszą wersje jajka. Myślę, że nie powinno być problemu już - mi się narazie te problemy skończyły.


  • 0

#8 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 15:05

@Roley, dobra wiadomość... jak dobrze rozumiem, nie masz tych problemów teraz na Debianie... ale miałeś podobne problemy na...? na czym na CentOS?

 

 


  • 0

#9 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 15:11

A no na Debianie. Tylko, że to było na jajku OVH.


  • 1

#10 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 15:27

@Roley, sorry nie kumam co to jest jajko ovh? Teraz jesteś na Debianie i jesteś happy tak? Pracowałeś na Ubuntu także?

 

PS. OK chyba chodzi o kernel czyli jajko, na nic innego nie mogę wpaść :rolleyes:


Edytowany przez sz00gun, 31 grudzień 2016 - 15:31.

  • 1

#11 SiXwishlist

SiXwishlist

    Freedom Forever

  • Firma Bronze
  • PipPipPipPipPipPipPipPip
  • 2366 postów
  • Skąd:Great Britain
  • Firma:SiXwishlist

Napisany 31 grudzień 2016 - 15:37

Według mojej skromnej opinii ten serwer nie jest po prostu dobrze skonfigurowany/zabezpieczony i wykłada się. Spróbuj zainstalować https://nixstats.com co pozwoli tobie zebrać logi na temat ostatnich działających procesów i ruchu na karcie sieciowej. 


  • 2

#12 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 15:38

Kernel=jajko.

 

Pracuje tylko na Debianie. Ubuntu miałem tylko na Public Cloud.


  • 0

#13 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 15:57

@SiXwishlist wow! super narzędzie zaraz sprawdzę co i jak. Dzięki

 

@Rolej OK, dzięki za sugestie.

 

Wczoraj kupiłem nowy serwer, piszą 120s. i gotowy... czemu już 2 dzień.... masakra z tym OVH i SYS. Za bardzo nie mogę narzekać bo sa najtańsi na rynku...


  • 0

#14 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 15:59

@SiXwishlist wow! super narzędzie zaraz sprawdzę co i jak. Dzięki

 

@Rolej OK, dzięki za sugestie.

 

Wczoraj kupiłem nowy serwer, piszą 120s. i gotowy... czemu już 2 dzień.... masakra z tym OVH i SYS. Za bardzo nie mogę narzekać bo sa najtańsi na rynku...

 

Powiem Ci, że trzeba naprawdę trafić na wolną maszynę. Ja nie miałem żadnych problemów z instalacją czy to w SYS, Kimsufi czy w WAW1. Jakby był jakiś problem z serwerem to daj znać na PW ;)


  • 0

#15 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 19:07

Według mojej skromnej opinii ten serwer nie jest po prostu dobrze skonfigurowany/zabezpieczony i wykłada się. Spróbuj zainstalować https://nixstats.com co pozwoli tobie zebrać logi na temat ostatnich działających procesów i ruchu na karcie sieciowej. 

Fajny ten nixstats.com jednak myślę, że nie pomoże mi jednak w przyszłości jak będzie crash, gdyż to narzędzie bardzo podobne jak https://github.com/firehol/netdata/ i w przypadku down'a nic mi nie podpowie. Nawet SyS ma prostą historię monitoringu load,memory itp.

 

Ja potrzebuje coś co... no nie wiem, chyba tylko migracja na inny system może mi coś więcej podpowiedzieć...


  • 0

#16 SiXwishlist

SiXwishlist

    Freedom Forever

  • Firma Bronze
  • PipPipPipPipPipPipPipPip
  • 2366 postów
  • Skąd:Great Britain
  • Firma:SiXwishlist

Napisany 31 grudzień 2016 - 19:14

Przed padem zobaczysz historię procesów które były uruchomione i w której chwili się urywają. Tak jak pisałem problem jest z konfiguracją nie ze sprzętem. Swoją drogą dlaczego zrezygnowałeś z panelu Plesk skoro niby wszystko działało?


  • 1

#17 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 19:31

Plesk był dołączony do OVH za darmo, teraz mam SYS i muszę mieć coś darmowego więc padło na Virtualmin i nie żałuję, myślę że jest bardzo dobry i łatwy w obsłudze.


  • 0

#18 SiXwishlist

SiXwishlist

    Freedom Forever

  • Firma Bronze
  • PipPipPipPipPipPipPipPip
  • 2366 postów
  • Skąd:Great Britain
  • Firma:SiXwishlist

Napisany 31 grudzień 2016 - 19:43

Plesk był dołączony do OVH za darmo, teraz mam SYS i muszę mieć coś darmowego więc padło na Virtualmin i nie żałuję, myślę że jest bardzo dobry i łatwy w obsłudze.

 

Przy 8 stronach cena panelu Plesk dla 10 domen wynosi niecałe 5 euro . Nie twierdzę że Virtualmin jest zły ale trzeba go umieć ogarnąć bo sam tego nie zrobi. Zresztą i sam Virtualmin ma opcje płatnych planów. Niemniej myślę że jak byś zlecił komuś by przejrzał konfigurację eliminując standardowe ustawienia serwer by działał jak należy. W innym przypadku jest to szukanie niewiadomej bo to co jest tz default nie powinno być stosowane produkcyjnie. To tylko taka wyjściowa konfiguracja.


  • 0

#19 sz00gun

sz00gun

    Czasami na forum

  • Użytkownicy
  • 29 postów
  • Imię:M

Napisany 31 grudzień 2016 - 19:53

Może i racja, ale że zacząłem od Pleska i wiem że chodzi niezawodnie to często porównuje pliki konfiguracyjne obu paneli i praktycznie są podobne, jak coś nie tak to nastawiam jak w Plesku...

 

Złe doświadczenie mam z http://mysqltuner.com/ "optymalne" ustawienia bazy wygenerowane przez ten skrypt zawieszał mi kompa podczas backupu.

 

Dlatego myślę "simplest the best".... nie ma co za bardzo kombinować, bo się przekombinuje...


  • 0

#20 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 31 grudzień 2016 - 22:25

Może i racja, ale że zacząłem od Pleska i wiem że chodzi niezawodnie to często porównuje pliki konfiguracyjne obu paneli i praktycznie są podobne, jak coś nie tak to nastawiam jak w Plesku...

 

Złe doświadczenie mam z http://mysqltuner.com/ "optymalne" ustawienia bazy wygenerowane przez ten skrypt zawieszał mi kompa podczas backupu.

 

Dlatego myślę "simplest the best".... nie ma co za bardzo kombinować, bo się przekombinuje...

 

Trochę to niemożliwe. Czym robiłeś backup bazy?


  • 0






Także otagowane jednym lub więcej z tych słów kluczowych: crash, linux, freeze, centos, virtualmin, webmin

0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników