Skocz do zawartości


 

Zdjęcie

Problem z konfiguracją HTTPS na Apache (owncloud)

Problem z konfiguracją HTTPS na Apache (owncloud) apache apache2 php error 500

  • Proszę się zalogować aby odpowiedzieć
1 odpowiedzi na ten temat

Problem z konfiguracją HTTPS na Apache (owncloud)

#1 gagorski

gagorski

    Nowy użytkownik

  • Użytkownicy
  • 13 postów
  • Firma:own
  • Imię:Grzegorz Artur
  • Nazwisko:Górski

Napisany 19 maj 2016 - 21:34

Próbuję ostatnio skonfigurować owncloud na VPS. Chciałbym, aby wykorzystywany był protokół HTTPS. niestety po konfiguracji jakiej dokonałem przy każdej próbie wywołania pliku PHP otrzymuję error 500

    Internal Server Error
 
    The server encountered an internal error and was unable to complete your request.
    Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
    More details can be found in the server log.

 

 

 
 
W error_log:
 
 
   [Wed May 18 20:19:35.288249 2016] [ssl:info] [pid 22473] [client 89.187.231.134:59370] AH01964: Connection to child 1 established (server owncloud.XXX.cloud:443)
    [Wed May 18 20:19:35.288517 2016] [ssl:debug] [pid 22473] ssl_engine_kernel.c(1928): [client 89.187.YYY.ZZZ:59370] AH02044: No matching SSL virtual host for servername own.XXX.cloud found (using default/first virtual host)
    [Wed May 18 20:19:35.357846 2016] [ssl:debug] [pid 22473] ssl_engine_kernel.c(1854): [client 89.187.YYY.ZZZ:59370] AH02041: Protocol: TLSv1.2, Cipher: ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
    [Wed May 18 20:19:35.421707 2016] [ssl:info] [pid 22473] (70014)End of file found: [client 89.187.YYY.ZZZ:59370] AH01991: SSL input filter read failed.
    [Wed May 18 20:19:35.421924 2016] [ssl:debug] [pid 22473] ssl_engine_io.c(1003): [client 89.187.YYY.ZZZ:59370] AH02001: Connection closed to child 1 with standard shutdown (server owncloud.XXX.cloud:443)
    [Wed May 18 20:19:35.487962 2016] [ssl:info] [pid 22474] [client 89.187.231.134:59371] AH01964: Connection to child 2 established (server owncloud.XXX.cloud:443)
    [Wed May 18 20:19:35.488336 2016] [ssl:debug] [pid 22474] ssl_engine_kernel.c(1928): [client 89.187.YYY.ZZZ:59371] AH02044: No matching SSL virtual host for servername own.XXX.cloud found (using default/first virtual host)
    [Wed May 18 20:19:35.558679 2016] [ssl:debug] [pid 22474] ssl_engine_kernel.c(1854): [client 89.187.YYY.ZZZ:59371] AH02041: Protocol: TLSv1.2, Cipher: ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
    [Wed May 18 20:19:35.628110 2016] [ssl:debug] [pid 22474] ssl_engine_kernel.c(244): [client 89.187.YYY.ZZZ:59371] AH02034: Initial (No.1) HTTPS request received for child 2 (server owncloud.XXX.cloud:443)
    [Wed May 18 20:19:35.628431 2016] [authz_core:debug] [pid 22474] mod_authz_core.c(809): [client 89.187.YYY.ZZZ:59371] AH01626: authorization result of Require all granted: granted
    [Wed May 18 20:19:35.628539 2016] [authz_core:debug] [pid 22474] mod_authz_core.c(809): [client 89.187.YYY.ZZZ:59371] AH01626: authorization result of <RequireAny>: granted
    [Wed May 18 20:19:35.689656 2016] [ssl:debug] [pid 22474] ssl_engine_io.c(1003): [client 89.187.YYY.ZZZ:59371] AH02001: Connection closed to child 2 with standard shutdown (server owncloud.XXX.cloud:443)
 
w acces_log:
 
   
 89.187.YYY.ZZZ - - [18/May/2016:20:23:05 +0200] "GET /index.php HTTP/1.1" 500 289 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36"
 
mój plik konfiguracyjny vhost:

    owncloud:/etc/apache2/vhosts.d # cat owncloud.conf
    <VirtualHost *:80>
    
    #### Redirect to port 443 ###
    RewriteEngine on
    ReWriteCond %{SERVER_PORT} !^443$
    RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]
    #### End of Redirection configuration ###
    
    DocumentRoot /srv/www/htdocs/owncloud/
    <Directory /srv/www/htdocs/owncloud/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require all granted
    </Directory>
    
    </VirtualHost>
    
    <VirtualHost *:443>
    
    ####Configuration for SSL #####
    SSLEngine on
    SSLCertificateFile /etc/apache2/ssl/owncloud.pem
    SSLCertificateKeyFile /etc/apache2/ssl/owncloud.key
    #### End of SSL Configuration ####
    
    DocumentRoot /srv/www/htdocs/owncloud/
    <Directory /srv/www/htdocs/owncloud/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require all granted
    </Directory>
    </VirtualHost>
 
załadowane moduły apache:
 
    owncloud:/etc/apache2/vhosts.d # apache2ctl -M
    [Wed May 18 20:28:37.076507 2016] [so:warn] [pid 22581] AH01574: module rewrite_module is already loaded, skipping
    Loaded Modules:
     core_module (static)
     so_module (static)
     http_module (static)
     mpm_prefork_module (static)
     unixd_module (static)
     systemd_module (static)
     php5_module (shared)
     actions_module (shared)
     alias_module (shared)
     auth_basic_module (shared)
     authn_file_module (shared)
     authz_host_module (shared)
     authz_groupfile_module (shared)
     authz_core_module (shared)
     authz_user_module (shared)
     autoindex_module (shared)
     cgi_module (shared)
     dir_module (shared)
     env_module (shared)
     expires_module (shared)
     include_module (shared)
     log_config_module (shared)
     mime_module (shared)
     negotiation_module (shared)
     setenvif_module (shared)
     ssl_module (shared)
     socache_shmcb_module (shared)
     userdir_module (shared)
     reqtimeout_module (shared)
     authn_core_module (shared)
     rewrite_module (shared)
     headers_module (shared)
 
 
Zainstalowany system operacyjny:
owncloud:/srv/www/htdocs/owncloud # cat /etc/issue
Welcome to openSUSE Leap 42.1 - Kernel \r (\l).

Prosiłbym o wskazówki gdzie popełniam błąd, 

 

Pozdrawiam, 

G. 

 

  • 0

#2 Vasthi

Vasthi

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 647 postów

Napisany 19 maj 2016 - 22:27

Sprawdź log (data/OwnCloud.log)
  • 0






Także otagowane jednym lub więcej z tych słów kluczowych: apache, apache2, php, error 500

0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników