Skocz do zawartości


 

Zdjęcie

Nagły problem z wysyłaniem maili przez skrypt

Nagły problem z wysyłaniem maili przez skrypt php skrypt blokada wysyłki

  • Proszę się zalogować aby odpowiedzieć
6 odpowiedzi na ten temat

Nagły problem z wysyłaniem maili przez skrypt

#1 athbus

athbus

    Regularny użytkownik

  • WHT Pro
  • 98 postów
  • Imię:Marcin

Napisany 11 maj 2016 - 16:00

Mam taką dziwną sytuację. Otóż jest server vps i na nim skrypt do obsługi listy mailingowej. Wysyłka odbywa się poprzez smtp w Emaillabs. 

 

Skrypt sobie ładnie działał i nagle w czasie wczorajszej wysyłki po wysłaniu kilkuset maili skrypt zaczął zwracać błąd php (a dokładniej biblioteki swiftmailer):

 

Expected response code 250 but got code "", with message ""

 

Wyczytałem, że ten błąd może oznaczać jakieś problemy komunikacji między serwerami (ale także setki innychrzeczy). OVH (gdzie stoi vps) twierdzi, że nic nie blokują, ale problem ewidentnie dotyczy serwera, bo z innej maszyny wszystko działa poprawnie, a z tego serwera skrypt przestał współpracować także z innymi serwerami smtp. 

 

Gdzie mogę szukać problemu?

 

Dodam że, nic nie zmieniałem w skrypcie ani na serwerze - po prostu w czasie wysyłki odpalonej z crona nagle się wszystko wysypało. Ten sam skrypt na localhoscie nadal wysyła maile bez problemu. Myślę, że jednak jest jakiś problem z ruchem wychodzącym z OVH tylko nie wiem jak to "udowodnić"/sprawdzić.

 


  • 0

#2 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 11 maj 2016 - 16:07

emaillabs cię nie zablokowało?


  • 0

#3 athbus

athbus

    Regularny użytkownik

  • WHT Pro
  • 98 postów
  • Imię:Marcin

Napisany 11 maj 2016 - 16:12

Nie na pewno nie, bo z localhosta wysyłam bez problemu (to samo konto/ustawienia) - problem na pewno leży gdzieś w serwerze, bo z serwera nie mogę też wysłać np. z prywatnej skrzynki na o2.pl.


  • 0

#4 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 11 maj 2016 - 17:17

No, ale może cię ich firewall zablokował np. za nieudane próby logowania.


  • 0

#5 Fizyda

Fizyda

    Stały użytkownik

  • WHT Pro
  • PipPipPipPipPip
  • 495 postów

Napisany 11 maj 2016 - 18:05

A czy przypadkiem taka sytuacja nie wystąpi jeśli adres ip serwera trafił na jakąś czarną listę?


  • 0

#6 athbus

athbus

    Regularny użytkownik

  • WHT Pro
  • 98 postów
  • Imię:Marcin

Napisany 12 maj 2016 - 10:36

Napiszę jeszcze do emaillabs, ale tak jak pisałem nie mogę też korzystać z innych serwerów smtp - np. z o2.pl

 

//edit właśnie sprawdziłem i wszystko zaczęło działać... Niby fajnie, tylko ciekawe, gdzie leżał kłopot. Mam nadzieję, że się nie powtórzy


Edytowany przez athbus, 12 maj 2016 - 10:42.

  • 0

#7 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 12 maj 2016 - 10:44

Może miałeś czasową blokadę na firewallu emaillabs


  • 0






Także otagowane jednym lub więcej z tych słów kluczowych: php, skrypt, blokada wysyłki

0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników