Skocz do zawartości


 

Zdjęcie

[DA] Po dodaniu użytkownika muszę zrestartować VPS, bo nie wyświetla jego domeny

[DA] Po dodaniu użytkownika muszę zrestartować VPS, bo nie wyświetla jego domeny directadmin vpd domena

  • Proszę się zalogować aby odpowiedzieć
7 odpowiedzi na ten temat

[DA] Po dodaniu użytkownika muszę zrestartować VPS, bo nie wyświetla jego domeny

#1 czunkara

czunkara

    Nowy użytkownik

  • Użytkownicy
  • 6 postów

Napisany 24 luty 2016 - 10:14

Witam wszystkich i na wstępie chciałbym się przywitać :-)

 

Moi drodzy, mam pewien problem.

 

Kupiłem sobie jakiś czas temu w SLDC vps'a z directadmin. Wszystko stoi na Debian 7 x64.

 

Otóż problem polega na tym, że po zainstalowaniu DA, podpięciu głównej domeny (dajmy na to xxxcccsss.pl), w sekcji dns pojawia się już skonfigurowane ns1.xxxcccsss.pl i ns2.xxxcccsss.pl. Ok, dodałem domenę, wpisuję w przeglądarce xxxcccsss.pl i nie można wyświetlić strony. Zrestartowałem VPS'a i zaczytało stronę (standardowo "Welcome to the home of...")

 

Ok, domena działa, dns ustawione jak być powinne itp, widać witrynę w internecie. W swoim DA chcę podpiąć następną domenę i znów to samo... widać ją dopiero po restarcie, i to też nie od razu (trzeba chwilę odczekać).

 

Druga sprawa - dodaję użytkownika przez panel resellera, dodaję mu domenę w postaci nazwausera.xxxcccsss.pl i problem z widocznością jego domeny jest identyczny. Tam wyskakuje jeszcze błąd z quote, ale czytałem, że w sldc to norma.

 

Po utworzeniu konta usera pokazuje się komunikat

 

 

 

User fgsdfgsdfg created

 

Details

Unix User created successfully

Error with system Quotas
setquota: Mountpoint (or device) / not found or has no quota enabled. setquota: Not all specified mountpoints are using quota. 
Debug Guide
User's data directory created successfully
Domains directory created successfully
Domains directory created successfully in user's home

Domain Created Successfully

 

Dodam, że w DA w sekcji admina w sekcji DNS, wszystkie domeny mają ustawione rekordy ns na ns1.xxxcccsss.pl i ns2.xxxcccsss.pl, typy A na ip serwera itp.

 

 

Poradźcie koledzy co zrobić, bo restart vps'a za każdym dodaniem nowego usera czy nowej domeny raczej mija się z celem.

 

 

 

Apache 2.4.18 Running DirectAdmin 1.50.0 Running Exim 4.80.1 Running MySQL 5.6.12 Running Named 9.8.4 Running sshd Running dovecot 2.2.21 (5345f22) Running pure-ftpd 1.0.42 Running Php 5.5.32 Installed

 

Z góry dziękuję za pomoc. Nie martwcie się, nie będzie to kolejny "Hostink - kszak", jakich w dawnych czasach można było spotkać wiele w naszym kraju. VPS'ik czysto hobbystyczny, do podziału z kilkoma kumplami.

 

 

Aha - ta domena xxxcccsss.pl to oczywiście nie istnieje, została podana dla przykładu. Inna domena jest podpięta, ale nie chcę robić spamu, dlatego podałem taką.


Edytowany przez czunkara, 24 luty 2016 - 10:17.

  • 0

#2 behemoth

behemoth

    Weteran WHT

  • Firma Bronze
  • PipPipPipPipPipPipPipPip
  • 1236 postów
  • Skąd:Łódź
  • Firma:swhosting.pl
  • Imię:Jakub

Napisany 24 luty 2016 - 10:24

Odnośnie quoty:

http://help.directad.../item.php?id=42

 

Może po prostu za krótko czekasz po dodaniu domeny i bind się jeszcze nie przeładował po prostu?


  • 0

#3 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 24 luty 2016 - 10:27

Daj mu chwilę i poczekaj cierpliwie. DNSy to też nie jest 10 sekund i zmienione. To musi chwilę trwać.


  • 0

#4 czunkara

czunkara

    Nowy użytkownik

  • Użytkownicy
  • 6 postów

Napisany 24 luty 2016 - 11:23

Behemoth, czytałem ten wątek na helpie da. Niestety 

 

 

 

 If you're running a VPS with a "simfs" file system, quotas usually cannot be enabled with normal means.

 

 

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent

permitted by applicable law.
Last login: Tue Feb 23 19:37:19 2016 from 94.40.92.1
root@defaultvps:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/simfs      100G  2.8G   98G   3% /
none            1.0G  4.0K  1.0G   1% /dev
none            205M   68K  205M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            410M   24K  410M   1% /run/shm
none            100M     0  100M   0% /run/user
root@defaultvps:~#
 

więc quoty sobie chwilowo odpuszczam. Na razie walczę z tymi domenami.

 

 

Mam hosting w cal.pl i tam jak dodaję domenę, to wydaje mi się, że jest ona od razu widoczna. Może mam mylne wrażenie.

 

Spróbuję dodać domenę i nie restartowć vps'a. Może faktycznie macie rację. Dam znać po południu jak sytuacja.

 

Póki co, serdeczne dzięki za pomoc :-) I jeśli ktoś ma kolejne pomysły, proszę pisać :-)

 


  • 0

#5 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 24 luty 2016 - 11:30

Na openvz musiałbyś pisać do supportu z quotą.


Edytowany przez Kamikadze, 24 luty 2016 - 11:30.

  • 0

#6 czunkara

czunkara

    Nowy użytkownik

  • Użytkownicy
  • 6 postów

Napisany 26 luty 2016 - 00:41

Niestety coś jest nie tak. Dodałem nowego usera z domeną w formacie "nazwausera.xxxcccsss.pl" wczoraj i nic, nie widać go było. Pomógł restart VPS'a.

 

Myślałem, że zadziała:

 

 

service bind9 reload

service bind9 restart

service named reload

service named restart

 

ale niestety nie zadziałało. Pomógł dopiero całkowity reboot.

 

Zmieniłem też u rejestratora dns innej wcześniej zakupionej domeny. Domenę podpiąłem w DA, poczekałem też z pół dnia no i zacząłem ją widzieć dopiero po restarcie VPS.

 

Już sam nie wiem, co robić. Od tygodnia siedzę i czytam googla i nic :-( ...


  • 0

#7 Gość_l3szcz_*

Gość_l3szcz_*
  • Goście

Napisany 27 luty 2016 - 15:56

A pinguje domena na Twoim IP? Jak tak to restart apache i zmień lokalnie DNS na google (8.8.8.8, 8.8.4.4)


  • 0

#8 czunkara

czunkara

    Nowy użytkownik

  • Użytkownicy
  • 6 postów

Napisany 27 luty 2016 - 16:12

Domena pinguje na moim IP.

 

Spróbuję z tymi dns'ami od googla. O efektach poinformuję.

 

Wielkie dzięki :-)


  • 0






Także otagowane jednym lub więcej z tych słów kluczowych: directadmin, vpd, domena

0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników