Skocz do zawartości


 

Zdjęcie

MySQL z dużą ilością danych

MySQL z dużą ilością danych

  • Proszę się zalogować aby odpowiedzieć
28 odpowiedzi na ten temat

MySQL z dużą ilością danych

#1 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 02 październik 2015 - 12:45

Witam serdecznie,

Mam taką tabelkę:

REATE TABLE IF NOT EXISTS `kategorie` (
  `id` bigint(20) UNSIGNED NOT NULL,
  `tytul` varchar(85) COLLATE utf8_unicode_ci DEFAULT NULL,
  `domena_url` varchar(100) COLLATE utf8_unicode_ci DEFAULT NULL,
  `enable` int(11) NOT NULL DEFAULT '0',
  `level` int(11) NOT NULL DEFAULT '0',
  `parent_id` int(11) NOT NULL DEFAULT '0'
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
 
--
-- Indeksy dla zrzutów tabel
--
 
--
-- Indexes for table `cms_kategorie`
--
ALTER TABLE `cms_kategorie`
  ADD PRIMARY KEY (`bf_id`),
  ADD UNIQUE KEY `bf_id` (`bf_id`),
  ADD KEY `bf_id_2` (`bf_id`);
 
--
-- AUTO_INCREMENT for dumped tables
--
 
--
-- AUTO_INCREMENT dla tabeli `cms_kategorie`
--
ALTER TABLE `cms_kategorie`
  MODIFY `bf_id` bigint(20) UNSIGNED NOT NULL AUTO_INCREMENT;

Mój serwer: http://www.online.ne...rver/dedibox-xc - z hdd sata3

Tabela ma 1.5GB.
 
 
Mój /my.cnf:
[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
symbolic-links=0
max_connections=600
max_user_connections=400
wait_timeout=30
interactive_timeout=50
long_query_time=5
#log-queries-not-using-indexes
#log-slow-queries=/var/log/mysql/log-slow-queries.log
 
#innodb_use_native_aio = 0
innodb_file_per_table
 
[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
 
thread_cache_size = 256
table_cache = 1024
key_buffer = 64M
sort_buffer_size = 256K
read_buffer_size = 256K
read_rnd_buffer_size = 256K
max_allowed_packet = 1M
tmp_table_size=64M
 
 
Niestety strony ładują się dość długo. Czy da się to jakoś przyśpieszyć?
Czy raczej to problem serwera?

  • 0

#2 Gość_Kamikadze_*

Gość_Kamikadze_*
  • Goście

Napisany 02 październik 2015 - 14:51

Możesz zoptymalizować zapytania, stworzyć / zmienić indeksowanie.

 

Tabela 1.5GB danych nie powinna mocno "przymulać". Sprawdź wolne zapytania i indeksy najpierw.

 

Później możesz pobawić się mysqltuner.pl


  • 0

#3 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 02 październik 2015 - 15:39

Index mam założony. 

 


  • 0

#4 Bartosz Z

Bartosz Z

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 833 postów
  • Skąd:Lubelskie
  • Imię:Bartosz

Napisany 02 październik 2015 - 15:41

Jak używasz MySQL to możesz zmienić go na Percone :)
  • 0

#5 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 02 październik 2015 - 16:11

Wolałbym pozostać przy MySQL bo to jako tako rozumiem ;-)

 

Wyczytałem że problemem może być ten random();

Ponoć trzeba napisać jakąś procedurę to losowań. Kombinuję z czymś takim:

DELIMITER $$
DROP PROCEDURE IF EXISTS getRandomRecords$$
CREATE PROCEDURE getRandomRecords(IN cnt INT)
 
BEGIN
    DROP TEMPORARY TABLE IF EXISTS randomRecords;
    CREATE TEMPORARY TABLE randomRecords ( `rand_id` BIGINT, `tytul` VARCHAR(85),  `domena_url` VARCHAR(100) );
 
    loop_random: LOOP
        IF cnt < 1 THEN 
            LEAVE loop_random;
        END IF;
 
        INSERT INTO randomRecords
            SELECT r1.id, r1.tytul, r3.domena_url  FROM `kategorie` AS r1 JOIN
                (SELECT (RAND() *
                    (SELECT MAX(id) FROM `kategorie`)) AS id) AS r2
            WHERE r1.id >= r2.id ORDER BY r1.id ASC LIMIT 1;
        SET cnt = cnt - 1;
    END LOOP loop_random;
 
SELECT * FROM randomRecords;
END$$
DELIMITER ; 


Wiesz może czy to się jakoś "trzyma"?

 

Mój kod php na stronie internetowej wygląda następująco:
 
$miasta = Array();
$stmt = $db->prepare("select tytul, domena_url, id FROM kategorie1   WHERE enable= 1  ORDER by RAND()  ASC limit 50;");
$stmt->execute();
    foreach ($stmt as $rowX) {
        array_push($miasta, $rowX['tytul']);
    } 
$stmt->closeCursor();

$produkty  = Array();
$stmt = $db->prepare("select tytul, domena_url, id FROM kategorie2   WHERE enable= 1  ORDER by RAND()  ASC limit 50;");
$stmt->execute();
    foreach ($stmt as $rowX) {
        array_push($produkty, $rowX['tytul']);
    }
$stmt->closeCursor();

$res = array();
foreach($miasta as $val) {
    $nazwa_miasta = baza_odczyt($val .' ' . array_shift($produkty));
    echo "<a href='".$portal_url."' title='".$nazwa_miasta."'>".$nazwa_miasta."</a>, ";
}  

 
Wie ktoś może jak to powinno wyglądać?

  • 0

#6 Bartosz Z

Bartosz Z

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 833 postów
  • Skąd:Lubelskie
  • Imię:Bartosz

Napisany 02 październik 2015 - 16:17

Percona jest w 100% zgodna z MySQL :P
  • 0

#7 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 02 październik 2015 - 16:45

OK, wygenerowało mi nowy plik na tej percona my.cns:

# Generated by Percona Configuration Wizard (http://tools.percona.com/) version REL5-20120208
# Configuration name server generated for trifek@icloud.com at 2015-10-02 15:19:15

[mysql]

# CLIENT #
port                           = 3306
socket                         = /var/lib/mysql/mysql.sock

[mysqld]

# GENERAL #
user                           = mysql
default-storage-engine         = InnoDB
socket                         = /var/lib/mysql/mysql.sock
pid-file                       = /var/lib/mysql/mysql.pid

# MyISAM #
key-buffer-size                = 45M
myisam-recover                 = FORCE,BACKUP

# SAFETY #
max-allowed-packet             = 16M
max-connect-errors             = 1000000

# DATA STORAGE #
datadir                        = /var/lib/mysql/

# BINARY LOGGING #
log-bin                        = /var/lib/mysql/mysql-bin
expire-logs-days               = 14
sync-binlog                    = 1

# CACHES AND LIMITS #
tmp-table-size                 = 32M
max-heap-table-size            = 32M
query-cache-type               = 0
query-cache-size               = 0
max-connections                = 500
thread-cache-size              = 60
open-files-limit               = 65535
table-definition-cache         = 1024
table-open-cache               = 2048

# INNODB #
innodb-flush-method            = O_DIRECT
innodb-log-files-in-group      = 2
innodb-log-file-size           = 256M
innodb-flush-log-at-trx-commit = 1
innodb-file-per-table          = 1
innodb-buffer-pool-size        = 6G

# LOGGING #
log-error                      = /var/lib/mysql/mysql-error.log
log-queries-not-using-indexes  = 1
slow-query-log                 = 1
slow-query-log-file            = /var/lib/mysql/mysql-slow.log

ale dalej muli :(


  • 0

#8 gutek

gutek

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 209 postów
  • Skąd:Wrocław

Napisany 02 październik 2015 - 17:44

Sprawdź w jakim trybie pracuje procesor, bo u mnie kiedyś bardzo wolno działał mysql ze względu na ograniczanie mocy cpu. np. cat /proc/cpuinfo ile wskaże dla każdego rdzenia Mhz i czy jest to zgodne z parametrami Twojego cpu.

 

Ja mam tabele po kilkanaście/kilkadziesiąt gb ale na dyskach ssd i szybszym zegarze do tego indeksy i odpowiednie zapytania i nie mam problemów z wydajnością.


Edytowany przez gutek, 02 październik 2015 - 18:33.

  • 0

#9 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 02 październik 2015 - 20:45

processor wyglada ok:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 0
cpu cores       : 8
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 1
cpu cores       : 8
apicid          : 2
initial apicid  : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 2
cpu cores       : 8
apicid          : 4
initial apicid  : 4
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 3
cpu cores       : 8
apicid          : 6
initial apicid  : 6
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 4
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 4
cpu cores       : 8
apicid          : 8
initial apicid  : 8
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 5
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 5
cpu cores       : 8
apicid          : 10
initial apicid  : 10
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 6
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 6
cpu cores       : 8
apicid          : 12
initial apicid  : 12
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 7
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 7
cpu cores       : 8
apicid          : 14
initial apicid  : 14
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

ponoć ten rand() jest taki zasobożerny.... nie wiem też czy ten atom jest nie za słaby ;/


  • 0

#10 gutek

gutek

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 209 postów
  • Skąd:Wrocław

Napisany 02 październik 2015 - 23:51

Atom to jedno ale najpierw zainteresuj się dlaczego system przydziela 1200 Mhz a nie pełną wartość czyli 2400 Mhz, nie wiem jaką masz dystrybucje ale na debianie pomaga instalacja cpufrequtils, ustawienie goveriora na performance i dodanie w /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable"

Według mnie obecnie mysql pracuje na procesorze 1200 Mhz czyli "wolno". :) Sam miałem taki problem i sporo czasu straciłem na szukanie pomocy, w tym tutaj na forum jest wątek, gdzie kilka osób pomogło sugerując właśnie to jako przyczynę problemu z wolnym mysqlem


  • 1

#11 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 03 październik 2015 - 00:25

Dziękuję bardzo :) Zrobiłem według tego poradnika:

http://unix.stackexc...rnor-nice-error

 

I teraz mam:

processor       : 7
vendor_id       : GenuineIntel
cpu family      : 6
model           : 77
model name      : Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
stepping        : 8
microcode       : 289
cpu MHz         : 2401.000
cache size      : 1024 KB
physical id     : 0
siblings        : 8
core id         : 7
cpu cores       : 8
apicid          : 14
initial apicid  : 14
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch ida arat epb dts tpr_shadow vnmi flexpriority ept vpid smep erms
bogomips        : 4800.19
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

Pełną prędkość :)

 

Tylko po restarcie znowu wraca do tych 1200Mhz :( i muszę za każdym razem wpisywać  cpupower frequency-set --governor performance

 

Da się to jakoś "zapamiętać"?


Mój grub wygląda tak:

[root@dom ~]# nano /etc/grub.conf
  GNU nano 2.0.9                        File: /etc/grub.conf

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/sda2
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable"
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS 6 (2.6.32-573.7.1.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-573.7.1.el6.x86_64 ro root=UUID=7a3ded90-7eaf-4d3c-b2f8-e1e8012992ea rd_NO_LUKS rd_$
        initrd /initramfs-2.6.32-573.7.1.el6.x86_64.img










  • 0

#12 gutek

gutek

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 209 postów
  • Skąd:Wrocław

Napisany 03 październik 2015 - 07:02

zrobiłeś update-grub ?
  • 0

#13 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 03 październik 2015 - 09:34

Przepraszam, że się wepnę w wątek, lecz...

Atom to jedno ale najpierw zainteresuj się dlaczego system przydziela 1200 Mhz a nie pełną wartość czyli 2400 Mhz, nie wiem jaką masz dystrybucje ale na debianie pomaga instalacja cpufrequtils, ustawienie goveriora na performance i dodanie w /etc/default/grub


GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable"
Według mnie obecnie mysql pracuje na procesorze 1200 Mhz czyli "wolno". :) Sam miałem taki problem i sporo czasu straciłem na szukanie pomocy, w tym tutaj na forum jest wątek, gdzie kilka osób pomogło sugerując właśnie to jako przyczynę problemu z wolnym mysqlem


U siebie w Atomie również znalazłem tę podatność. Zrobiłem tak jak poradziłeś lecz nie mogę znaleźć nigdzie plików cpufrequtils w Debianie 8. Mógłbyś mnie nakierować gdzie je znaleźć?
  • 0

#14 trif

trif

    Regularny użytkownik

  • Użytkownicy
  • 84 postów

Napisany 03 październik 2015 - 09:36

nie ma takiego polecenia w centosie :(


to trzeba doinstalować :) Ja robiłem według tego: http://unix.stackexc...rnor-nice-error


  • 0

#15 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 03 październik 2015 - 09:41

Tylko, że w Debianie nie ma z kolei /lib/modules. Przynajmniej na wersji w kernelem OVH. Jeszcze na wirtualnej maszynie dzisiaj sprawdzę u siebie w domu czy cosik takiego znajdę.
  • 0

#16 gutek

gutek

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 209 postów
  • Skąd:Wrocław

Napisany 03 październik 2015 - 14:13

W debianie 7 i 8 wystarczy

apt-get install cpufrequtils

+ utworzenie governiora /etc/default/cpufrequtils

ENABLE="true"
GOVERNOR="performance"

+ dodanie wpisu w /etc/default/grub (u mnie dopiero to pozwalało, na poprawne działanie)

GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable"

I restart serwera.

 

PS. nie wiem jak to się ma do serwerów np w OVH, ale na maszynach gdzie się instaluje własną wersję np. debiana nie ma problemu.

 

@TRIF czy teraz mysql działa lepiej / tak jak powinien ?

 

Według mnie większość serwerów pracuje w trybie ONDEMAND :) co raczej nie przeszkadza w normalnej pracy wielu usług, ale przy mysql to jest masakra z tym.


Edytowany przez gutek, 03 październik 2015 - 14:15.

  • 1

#17 Rolej

Rolej

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 615 postów
  • Skąd:Szczecinek
  • Firma:Profil prywatny
  • Imię:Przemek
  • Nazwisko:Jagielski

Napisany 03 październik 2015 - 14:30

W moim przypadku zadziałało. Dzięki wielkie, plus leci ;)
  • 0

#18 Pan Kot

Pan Kot

    Mrrr

  • Zbanowani
  • PipPipPipPipPipPipPipPip
  • 2819 postów

Napisany 03 październik 2015 - 16:44

Zamiast instalować cpufrequtils lepiej zrekompilować kernela, zmienić governora na sztywno, wywalić inne, wywalić pstate (jeśli komuś przeszkadza) i masz pewność, że nic Ci tego governora nie zmieni, bo tylko jeden jest dostępny. Podobnie ma się sprawa z governorem I/O.

 

Do tego jest wiele innych rzeczy, które podobnie mogą wpłynąć na wydajność, chociażby frontswap/cleancache.

 

I tak, domyślnym governorem w przypadku OVH, i zapewne wielu innych providerów jest ondemand.


Edytowany przez Archi, 03 październik 2015 - 16:45.

  • 0

#19 gutek

gutek

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 209 postów
  • Skąd:Wrocław

Napisany 03 październik 2015 - 16:54

@up piszac governior I/O masz na myśli scheduler?
  • 0

#20 Pan Kot

Pan Kot

    Mrrr

  • Zbanowani
  • PipPipPipPipPipPipPipPip
  • 2819 postów

Napisany 03 październik 2015 - 20:23

Yup.


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników