Skocz do zawartości


 

Zdjęcie

Hosting z php 5.3 czy warto

Hosting z php 5.3 czy warto hosting z php 5.3

  • Proszę się zalogować aby odpowiedzieć
10 odpowiedzi na ten temat

Hosting z php 5.3 czy warto

#1 marcinmarcin

marcinmarcin

    Nowy użytkownik

  • Użytkownicy
  • 8 postów

Napisany 17 czerwiec 2015 - 09:34

Czy tworząc ofertę hostingową warto jeszcze w dzisiejszych czasach oferować php 5.3 ?

Jest to jakby nie było już niewspierana wersja więc ciężko na niej zapanować na serwerze np z kilkoma wersjami php.

Co o tym sądzicie?


  • 0

#2 Vasthi

Vasthi

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 650 postów

Napisany 17 czerwiec 2015 - 09:42

php 5.3 jest stare, aczkolwiek niektórzy klienci mogą żądać tylko i wyłącznie tej wersji chociaż przejście z 5.3 -> 5.4 nie powinno być tak bolesne jak 5.4 -> 5.5 (wycofano całe ext/mysql)


  • 0

#3 marcinmarcin

marcinmarcin

    Nowy użytkownik

  • Użytkownicy
  • 8 postów

Napisany 17 czerwiec 2015 - 09:50

Dzięki za szybką odpowiedź.

A jak w takiej sytuacji radzić sobie z "dziurami" w php53, które mogą zaowocować włamaniem, lub odmową usługi dostępu serwera, na którym będą użytkownicy z php 5.4-5.5 czy wyżej?


  • 0

#4 blfr

blfr

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1208 postów

Napisany 17 czerwiec 2015 - 10:02

Każdemu oddzielną VMkę albo chociaż kontener.
  • 0

#5 OneDistrict

OneDistrict

    Stały użytkownik

  • Użytkownicy
  • PipPipPipPipPip
  • 159 postów

Napisany 17 czerwiec 2015 - 11:19

Każdemu oddzielną VMkę albo chociaż kontener.

 

>współdzielony hosting

>wydzielona vmka/kontener


  • 0

#6 marcinmarcin

marcinmarcin

    Nowy użytkownik

  • Użytkownicy
  • 8 postów

Napisany 17 czerwiec 2015 - 11:21

To już niesmaowity spadek wydajności. Przy dajmy na to 300klientach 300 vm`ów?

 


  • 0

#7 samu

samu

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1178 postów
  • Imię:Jakub
  • Nazwisko:Szafrański

Napisany 17 czerwiec 2015 - 12:18

Przy kontenerach jak najbardziej ;)

 

Ja bym php 5.3 już olał. 10 miesięcy to bardzo dużo czasu, żeby się przenieść na nowszą wersję, a dokładnie 10 miesięcy temu przestało być wspierane php 5.3.


  • 2

#8 beliq

beliq

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 2121 postów

Napisany 18 czerwiec 2015 - 00:15

To zależy od targetu docelowej oferty.

Jeśli to ma być hosting dla mas, to PHP 5.3 jest absolutnie niezbędne.

Jeśli to ma być oferta dla power userów, można zacząć od 5.4/5.5.


  • 0

#9 Bartosz Z

Bartosz Z

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 863 postów
  • Skąd:Lubelskie
  • Imię:Bartosz

Napisany 18 czerwiec 2015 - 09:42

U nas jest trochę klientów z PHP 5.2 i nie ma miesiąca, żeby nowy klient nie wymagał PHP 5.2 ;)
Standardowo udostępniamy 5.3, 5.4 i 5.5.


  • 0

#10 marcinmarcin

marcinmarcin

    Nowy użytkownik

  • Użytkownicy
  • 8 postów

Napisany 18 czerwiec 2015 - 09:58

Więc php5.3 musi być.

A jak technicznie radzicie sobie z kilkoma wersjami php,

wszystko zainstalowane na jednym serwerze, czy może kilka serwerow + proxy?


  • 0

#11 Misiek08

Misiek08

    Weteran WHT

  • WHT Pro
  • PipPipPipPipPipPipPipPip
  • 1157 postów

Napisany 18 czerwiec 2015 - 18:22

W kilku już firmach było tak, że mieli na tym samym serwerze kilka wersji. Zależnie od serwera i rozwiązania stawiasz kilka wersji i zgodnie z tym co klient ustawi - tam kierujesz żądania. Kilka pul FPM (jeżeli jeden user może mieć kilka wersji PHP na raz - różne dla różnych stron).


  • 0





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników