Skocz do zawartości


 

Zdjęcie

środowisko developerskie - vagrant

środowisko developerskie - vagrant vagrant linux

  • Proszę się zalogować aby odpowiedzieć
1 odpowiedzi na ten temat

środowisko developerskie - vagrant

#1 c_tom

c_tom

    Czasami na forum

  • Użytkownicy
  • 50 postów
  • Skąd:Łódź
  • Imię:Tomasz

Napisany 12 grudzień 2014 - 21:11

Próbuje stworzyć środowisko developerskie oparte o Vagranta (+ puphpet) do którego będzie dostęp z zewnętrznego komputera (mały schemat poniżej). O ile wszystko ładnie śmiga na host1 o tyle w zewnątrz (z host2) nie ma dostępu przez przeglądarkę (na porcie 80). host2 pinguje do host1. 
 
Mogę prosić o pomoc czego brakuje  ?
host1 {
	ip: X
	/etc/hosts: {
		ip_Y -> test.dev
	}
	virtualbox1: {
		ip: Y
		apache: {
			vhost: test.dev
		}
	}
}

host2 {
	ip: Z
	/etc/hosts: {
		ip_X -> test.dev
	}

}
ps. próbowałem na host1 postawić Bind9, o ile z host1 domena test.dev była "dostępne" (po usunięcu wpisu w /etc/hosts na host1) o tyle z host2 wciąż nic.
Obstawiam, że nie potrafię odpowiednio skonfigurować binda na host1 lub czegoś brakuje w schemacie. 

  • 0

#2 c_tom

c_tom

    Czasami na forum

  • Użytkownicy
  • 50 postów
  • Skąd:Łódź
  • Imię:Tomasz

Napisany 13 grudzień 2014 - 18:45

problem częściowo się rozwiązał - podczas tworzenia pliku konfiguracyjnego (ja to robię przy pomocy puphpet.com) trzeba dodać parę portów dla przekierowania np. ( host: 8080 ; guest: 80).  

Niestety przy ustawieniu 80->80 to nie działa (otrzymuję ostrzeżenie, że przekierowania na porty < 1024 mogę nie działać prawidłowo). 

 

Niestety moja wiedza z administracji nie jest wystarczająca, stąd moje pytani:

jak przekierować zapytania przychodzące z zewnątrz na porcie 80 na (no własnie nie wiem czy na IP_Y:80 czy na IP_X:8080 )  ?

 

Z góry dziękuję za pomoc. 

 


  • 0






Także otagowane jednym lub więcej z tych słów kluczowych: vagrant, linux

0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników