Skocz do zawartości


 

Roundcube zmiana hasła

Roundcube zmiana hasła

  • Proszę się zalogować aby odpowiedzieć
2 odpowiedzi na ten temat

Roundcube zmiana hasła

#1 Gość_hdmagc_*

Gość_hdmagc_*
  • Goście

Napisany 21 listopad 2011 - 19:21

Witam.

Proszę o pomoc z dziwnym problemem dotyczącym braku możliwości zmiany hasła w roundcube.

Sam roundcube działa poprawnie.
W momencie, gdy chce zmienić hasło wywala mi 500 po długim oczekiwaniu.

Sprawdziłem logi i żadnej informacji, która mogłaby pomóc.

Na serwerze Debian squeeze+DA+fcgi
  • 0

#2 patrys

patrys

    Czarny charakter

  • Moderatorzy
  • PipPipPipPipPipPipPipPip
  • 2755 postów
  • Skąd:Słupsk / Szczecin
  • Firma:NetFS
  • Imię:Patryk
  • Nazwisko:Gorczyca

Napisany 21 listopad 2011 - 19:27

Problem z pluginem do zmiany hasła, nie jest on standardowy przy DA.
Sprawdź logi roundcube, co do logów 500 na pewno są w error logu.
  • 1
| Administracja serwerami - Potrzebujesz pomocy? Napisz! |

#3 Gość_hdmagc_*

Gość_hdmagc_*
  • Goście

Napisany 21 listopad 2011 - 19:43

Przewaliłem wszystkie logi. Specjalnie wyłączyłem wszystkie inne usługi, aby wyłapać błąd i nic. Zero informacji w logach. Jest info o zadziałaniu pluginu password, po czym żadnego błędu.

Reasumując, trochę spanikowałem. Przemyślałem konfiguracje tego pluginu i wprowadziłem jedna zmianę, dzięki której już zmienia hasło.

// DirectAdmin Driver options
// --------------------------
// The host which changes the password
// Use 'ssl://serverip' instead of 'tcp://serverip' when running DirectAdmin over SSL.
$rcmail_config['password_directadmin_host'] = 'tcp://localhost';

// TCP port used for DirectAdmin connections
$rcmail_config['password_directadmin_port'] = 2222;


Zmieniłem na:

// DirectAdmin Driver options
// --------------------------
// The host which changes the password
// Use 'ssl://serverip' instead of 'tcp://serverip' when running DirectAdmin over SSL.
$rcmail_config['password_directadmin_host'] = 'ssl://localhost';

// TCP port used for DirectAdmin connections
$rcmail_config['password_directadmin_port'] = 2222;


Tak to jest jak sie nie doczyta.

Może przyda sie potomnym.

Dziękuje za wszelkie wskazówki i chęć pomocy.

Do zamknięcia.
  • 1





0 użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników